您的位置:首页 > 其它

poj 3311 状态压缩DP

2014-10-01 11:53 295 查看
http://poj.org/problem?id=3311

Description

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before
he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you
to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating
the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting
any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from
location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input
3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output
8


解题思路:

                     利用Foyld算法求出0~n个点之间的最短路径,然后枚举所有状态,在if(s&(1<<(i-1)))的前提下:(1) if(s==(1<<(i-1))) dp[s][i]=dis[0][i]; (2)    if(s&(1<<(j-1))&&i!=j), dp[s][i]=min(dp[s^(1<<(i-1))][j]+dis[j][i],dp[s][i]); 状态转移。值得一提的是,走的路径是来回,最后所有的点都遍历完之后还要回到出发点,详见代码:

#include <stdio.h>
#include <iostream>
#include <string.h>
using namespace std;

const int inf=0x3f3f3f3f;
const int N=1<<11;

int dis[15][15],dp
[15];
int n;

int main()
{
while(~scanf("%d",&n)&&n)
{
for(int i=0;i<=n;i++)
for(int j=0;j<=n;j++)
scanf("%d",&dis[i][j]);
for(int k=0;k<=n;k++)
for(int i=0;i<=n;i++)
for(int j=0;j<=n;j++)
dis[i][j]=min(dis[i][j],dis[i][k]+dis[k][j]);
for(int s=0;s<1<<n;s++)
{
for(int i=1;i<=n;i++)
if(s&(1<<(i-1)))
{
if(s==(1<<(i-1)))
dp[s][i]=dis[0][i];
else
{
dp[s][i]=inf;
for(int j=1;j<=n;j++)
if(s&(1<<(j-1))&&i!=j)
dp[s][i]=min(dp[s^(1<<(i-1))][j]+dis[j][i],dp[s][i]);
}
}
}
int ans=dp[(1<<n)-1][1]+dis[1][0];
for(int i=2;i<=n;i++)
ans=min(ans,dp[(1<<n)-1][i]+dis[i][0]);
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: