您的位置:首页 > 其它

poj 3071 Football 概率dp

2014-09-29 16:53 344 查看
Football

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 3132Accepted: 1585
Description

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then,
the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared
the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, the jth value
on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 − pji for all i ≠ j, and pii = 0.0 for all i.
The end-of-file is denoted by a single line containing the number −1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the
double
data type instead
of
float
.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least
0.01.

Sample Input
2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1

Sample Output
2

Hint

In the test case above, teams 1 and 2 and teams 3 and 4 play against each other in the first round; the winners of each match then play to determine the winner of the tournament. The probability that team 2 wins the tournament in this case is:

P(2 wins) = P(2 beats 1)P(3 beats 4)P(2 beats 3) + P(2 beats 1)P(4 beats 3)P(2 beats 4)

= p21p34p23 + p21p43p24

= 0.9 · 0.6 · 0.4 + 0.9 · 0.4 · 0.5 = 0.396.
The next most likely team to win is team 3, with a 0.372 probability of winning the tournament.

Source

Stanford Local 2006

题意:有n组淘汰赛,对应2^n个球队,这些球队按淘汰赛规则晋级,问哪个球队最有希望拿冠军。

思路:如果是淘汰赛规则,那么第i轮他遇到的对手一定是某2^(i-1)队伍中的一个,这个规律很好找,找到了以后就可以写了。

转移方程:dp[i][j]+=dp[i-1][j]*dp[i-1][k]*a[j][k]

累加符号不会打,对应每个k都加一遍就对了。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
using namespace std;
const int N=(1<<7)+5;
const double eps=1e-5;
int n;
double a

,dp

;
int main()
{
while(scanf("%d",&n),n!=-1){
int l=1<<n;
for(int i=0;i<l;i++)
for(int j=0;j<l;j++)
scanf("%lf",&a[i][j]);
memset(dp,0,sizeof(dp));
for(int i=0;i<l;i++)
dp[0][i]=1;
for(int i=1;i<=n;i++){
for(int j=0;j<l;j++){
int q=j/(1<<i);
int o=j/(1<<i-1);
int k,e;
if(o%2){
k=q*(1<<i);
e=k+(1<<i-1);
}
else{
k=q*(1<<i)+(1<<i-1);
e=k+(1<<i-1);
}
for(;k<e;k++){
dp[i][j]+=dp[i-1][j]*dp[i-1][k]*a[j][k];
}
}
}
int id=0;
for(int i=0;i<l;i++){
if(dp
[i]>dp
[id])id=i;
}
printf("%d\n",id+1);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: