您的位置:首页 > 其它

poj 3254 Corn Fields (状态压缩DP)

2014-09-29 16:47 344 查看
Corn Fields

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 8041Accepted: 4287
Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares
are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice
as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways
he can choose the squares to plant.

Input

Line 1: Two space-separated integers: M and N

Lines 2..M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)
Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.
Sample Input
2 3
1 1 1
0 1 0

Sample Output
9

Hint

Number the squares as follows:

1 2 3
4


There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

思路:首先的得到相邻格子不能同时取的信息,然后,对于不能种的地也要舍去,最后求得不和上一行冲突的状态数总和。

#include<stdio.h>
#include<queue>
#include<map>
#include<string>
#include<string.h>
using namespace std;
#define N 25
const int mod=100000000;
int dp
[400];
int cur
; //记录当前行的土地信息,不能取得位置置1
int num[400]; //记录不和相邻格子冲突的取法
void inti()
{
int i,k;
for(i=k=0;i<(1<<12);i++)
{
if(i&(i<<1))
continue;
num[k++]=i;
}
//printf("%d\n",k);
}
int main()
{
int i,j,k,t,n,m;
inti();
while(scanf("%d%d",&n,&m)!=-1)
{
memset(cur,0,sizeof(cur));
for(i=0;i<n;i++)
{
for(j=0;j<m;j++)
{
scanf("%d",&t);
if(t==0)
cur[i]|=(1<<j);
}
}
int lim=1<<m;
for(i=0;num[i]<lim;i++)
{
if(cur[0]&num[i])
dp[0][i]=0;
else
dp[0][i]=1;
}
for(i=1;i<n;i++)
{
for(j=0;num[j]<lim;j++)
{
dp[i][j]=0;
if(num[j]&cur[i])
continue;
for(k=0;num[k]<lim;k++)
if(!(num[j]&num[k]))
dp[i][j]+=dp[i-1][k];
}
}
int ans=0;
for(i=0;num[i]<lim;i++)
ans=(ans+dp[n-1][i])%mod;
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: