您的位置:首页 > 其它

UVA_712 - S-Trees

2014-09-28 21:07 477 查看



S-Trees

A Strange Tree (S-tree) over the variable set

is a binary tree representing a Boolean function

.Each
path of the S-tree begins at theroot node and consists of n+1 nodes. Each of the S-tree's nodes has adepth, which is the amount of nodes between itself and the root (so the root has depth 0). The nodes with depth less thann
are called non-terminal nodes. All non-terminal nodes have two children: theright child and the
left child. Each non-terminal node is marked with some variablexi from the variable setXn. All non-terminal nodes with
the same depth are marked with the same variable, and non-terminal nodes with different depth are marked with different variables. So, there is a unique variablexi1
corresponding to the root, a unique variablexi2 corresponding to the nodes with depth 1, andso on. The sequence of the variables

is
called thevariable ordering. The nodes having depth n are called
terminal nodes. They have no children and are marked with either 0 or 1. Note that the variable ordering and the distribution of 0's and 1's on terminal nodes are sufficient to completely describe an S-tree.

As stated earlier, each S-tree represents a Boolean function f. If you have an S-tree and values for the variables

,then
it is quite simple to find out what

is: start with the root. Now repeat the following: if the node you are at is labelled
with a variablexi, then depending on whether the value of the variable is 1 or 0, you go its right or left child, respectively. Once you reach a terminal node, its label gives the value of the
function.



Figure 1: S-trees for the function


On the picture, two S-trees representing the same Boolean function,

,are shown. For the left
tree, the variable ordering is x1,x2,
x3, and for the right tree it isx3,x1,
x2.

The values of the variables

,are given as aVariable Values Assignment (VVA)



with

.For instance, (x1 = 1,x2
= 1 x3 = 0) would be a valid VVA forn = 3, resulting for the sample function above in the value


.The corresponding paths are shown bold in the picture.

Your task is to write a program which takes an S-tree and some VVAs and computes

as described above.

Input

The input file contains the description of several S-trees with associated VVAs which you have to process. Each description begins with a line containing a single integern,


,the depth of the S-tree. This is followed by a line describing the variable ordering of the S-tree. The format of that line
is xi1xi2 ...xin. (There will be exactlyn different
space-separated strings).So, for n = 3 and the variable orderingx3,
x1,x2, this line would look as follows:

x3 x1 x2

In the next line the distribution of 0's and 1's over the terminal nodes is given. There will be exactly 2n characters (each of which can be 0 or 1), followed by the new-line character.The characters
are given in the order in which they appear in the S-tree, the first character corresponds to the leftmost terminal node of the S-tree, the last one to its rightmost terminal node.

The next line contains a single integer m, the number of VVAs, followed bym lines describing them. Each of the
m lines contains exactly n characters (each of which can be 0 or 1), followed by a new-line character. Regardless of the variable ordering of the S-tree, the first character always describes the value ofx1,
the second character describes the value ofx2, and so on. So, the line

110

corresponds to the VVA (x1 = 1,x2 = 1,
x3 = 0).

The input is terminated by a test case starting with n = 0. This test case should not be processed.

Output

For each S-tree, output the line ``S-Tree #j:", wherej is the number of the S-tree. Then print a line that contains the value of

for
each of the givenm VVAs, where f is thefunction defined by the S-tree.

Output a blank line after each test case.

Sample Input

3
x1 x2 x3
00000111
4
000
010
111
110
3
x3 x1 x2
00010011
4
000
010
111
110
0


Sample Output

S-Tree #1:
0011

S-Tree #2:
0011


题意分析:

很简单的题意,意思是对一颗满二叉树,每一层代表一个0或者1变量,当等于0往左走,1往右走;求出最后达到叶子节点的值(会给出)

解题思路:

1. 必须运用满二叉树的性质,设当前节点为n,左边节点为2*n,右边卫2*n+1;

2. 必须映射好对应值,比如当顺序为x3,x1,x2;对于查询010(按照x1=0,x2=1.x3=0顺序赋值),此时x3为第0层,x1为第一层。x2为第二层

代码如下:

#include<iostream>
#include<string>
#include<map>
using namespace std;

map<int,int> tree;
int value[10];

int main()
{
int n,m,icase=0;
string str; int temp;
while(cin>>n&&n!=0)
{
int cnt=2<<(n-1);//The number of terminal node
for(int i=0;i<n;i++) {
cin>>str; temp=str[1]-'0';
value[i]=temp;
}

string s; cin>>s;  //input 2^n characters
string vva,result;
cin>>m;
for(int i=0;i<m;i++){
cin>>vva;//查询值
for(int j=0;j<n;j++) tree[value[j]]=int(vva[j]-'0');//完成对应值的映射
//寻找满二叉树的节点
int sum=1;
for(int j=0;j<n;j++){
if(tree[value[j]]==0) sum=sum*2;
else sum=sum*2+1;
}
result+=s[sum%cnt];
tree.clear();
}
cout<<"S-Tree #"<<++icase<<":"<<endl;
cout<<result<<endl<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: