您的位置:首页 > 其它

HDU 5045 Contest(DFS 回溯)

2014-09-28 20:14 267 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5045

Problem Description

In the ACM International Collegiate Programming Contest, each team consist of three students. And the teams are given 5 hours to solve between 8 and 12 programming problems.

On Mars, there is programming contest, too. Each team consist of N students. The teams are given M hours to solve M programming problems. Each team can use only one computer, but they can’t cooperate to solve a problem. At the beginning of the ith hour, they
will get the ith programming problem. They must choose a student to solve this problem and others go out to have a rest. The chosen student will spend an hour time to program this problem. At the end of this hour, he must submit his program. This program is
then run on test data and can’t modify any more.

Now, you have to help a team to find a strategy to maximize the expected number of correctly solved problems.

For each problem, each student has a certain probability that correct solve. If the ith student solve the jth problem, the probability of correct solve is Pij .

At any time, the different between any two students’ programming time is not more than 1 hour. For example, if there are 3 students and there are 5 problems. The strategy {1,2,3,1,2}, {1,3,2,2,3} or {2,1,3,3,1} are all legal. But {1,1,3,2,3},{3,1,3,1,2} and
{1,2,3,1,1} are all illegal.

You should find a strategy to maximize the expected number of correctly solved problems, if you have know all probability



Input

The first line of the input is T (1 ≤ T ≤ 20), which stands for the number of test cases you need to solve.

The first line of each case contains two integers N ,M (1 ≤ N ≤ 10,1 ≤ M ≤ 1000),denoting the number of students and programming problem, respectively.

The next N lines, each lines contains M real numbers between 0 and 1 , the jth number in the ith line is Pij .



Output

For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then a single real number means the maximal expected number of correctly solved problems if this team follow the best strategy, to five digits
after the decimal point. Look at the output for sample input for details.



Sample Input

1
2 3
0.6 0.3 0.4
0.3 0.7 0.9




Sample Output

Case #1: 2.20000




Source

2014 ACM/ICPC Asia Regional Shanghai Online

题意:

N个人,M道题,M个小时,每个人做一道题需要1个小时。给出一个N*M的矩阵代表每个人做对每道题的概率。然后要求在任何时刻,任意两个人的敲题时间差不能大于1,也就是说,m道题要分成多段长度为n的最优排列;

PS:

好像官方解法是状压+DP吧,我用的DFS

代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;

double a[17][1017];
double anst;
int vis[17];
int goal;
void DFS(int tt, int num, double ans)
{
    //如果当前的答案加上剩下的题目(假设概率全为1)的概率比之前记录的答案还小
    //那么就不用再继续往下搜
    if(anst!=0 && ans+goal-tt < anst)
        return ;
    if(tt == goal)
    {
        if(ans > anst)
            anst = ans;
        return ;
    }
    for(int i = 0; i < num; i++)
    {
        if(!vis[i])
        {
            vis[i] = 1;
            DFS(tt+1,num,ans+a[i][tt]);
            vis[i] = 0;
        }
    }
}
int main()
{
    int t, cas = 0;
    int n, m;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(int i = 0; i < n; i++)
        {
            for(int j = 0; j < m; j++)
            {
                scanf("%lf",&a[i][j]);
            }
        }
        int pre = 0;
        goal = 0;
        double ans = 0;
        int tt;
        while(pre < m)
        {
            anst = 0;
            if(m-pre >= n)
                tt = n;
            else
                tt = m-pre;
            goal += tt;
            memset(vis,0,sizeof(vis));
            DFS(pre,n,0);
            pre += tt;
            ans += anst;
        }
        printf("Case #%d: %.5lf\n",++cas,ans);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: