您的位置:首页 > 其它

Count the string(记忆化搜索)

2014-09-28 15:19 323 查看

Count the string

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4899 Accepted Submission(s): 2313


题目连接



Problem Description
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:

s: "abab"

The prefixes are: "a", "ab", "aba", "abab"

For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab",
it is 2 + 2 + 1 + 1 = 6.

The answer may be very large, so output the answer mod 10007.



Input
The first line is a single integer T, indicating the number of test cases.

For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.



Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.


Sample Input
1
4
abab




Sample Output
6




Author
foreverlin@HNU


Source
HDOJ Monthly Contest – 2010.03.06

记忆化搜索: 预先记录前一状态的位置.

AC代码:

#include <iostream>
#include <cstring>
#include <cstdio>

using namespace std;

const int M = 1e5 * 2 + 100;
char s[M];
int map[M];

int main()
{
    int T,n;
    scanf("%d",&T);
    while(T--)
    {
        memset(map,0,sizeof(map));
        scanf("%d %s",&n,s);
        int tp,len,ans;
        len = strlen(s);
        map[0] = ans = 0;
        tp = 1;
        for(int i = 1; s[i]; i++)
            if(s[i] == s[0]) map[tp++] = i;
        ans += tp;
        for(map[0]++; map[0] < len; map[0]++)
        {
            int temp = 1;
            for(int i = 1; i < tp; i++)
                if(s[map[i] + 1] == s[map[0]]) map[temp++] = map[i] + 1;
            tp = temp;
            ans += tp;
            if(ans > 10007) ans %= 10007;
        }
        printf("%d\n",ans);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: