您的位置:首页 > 其它

hdu 5045(状态压缩dp)

2014-09-28 14:57 369 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5045

Contest

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 348 Accepted Submission(s): 157



Problem Description
In the ACM International Collegiate Programming Contest, each team consist of three students. And the teams are given 5 hours to solve between 8 and 12 programming problems.

On Mars, there is programming contest, too. Each team consist of N students. The teams are given M hours to solve M programming problems. Each team can use only one computer, but they can’t cooperate to solve a problem. At the beginning of the ith hour, they
will get the ith programming problem. They must choose a student to solve this problem and others go out to have a rest. The chosen student will spend an hour time to program this problem. At the end of this hour, he must submit his program. This program is
then run on test data and can’t modify any more.

Now, you have to help a team to find a strategy to maximize the expected number of correctly solved problems.

For each problem, each student has a certain probability that correct solve. If the ith student solve the jth problem, the probability of correct solve is Pij .

At any time, the different between any two students’ programming time is not more than 1 hour. For example, if there are 3 students and there are 5 problems. The strategy {1,2,3,1,2}, {1,3,2,2,3} or {2,1,3,3,1} are all legal. But {1,1,3,2,3},{3,1,3,1,2} and
{1,2,3,1,1} are all illegal.

You should find a strategy to maximize the expected number of correctly solved problems, if you have know all probability


Input
The first line of the input is T (1 ≤ T ≤ 20), which stands for the number of test cases you need to solve.

The first line of each case contains two integers N ,M (1 ≤ N ≤ 10,1 ≤ M ≤ 1000),denoting the number of students and programming problem, respectively.

The next N lines, each lines contains M real numbers between 0 and 1 , the jth number in the ith line is Pij .


Output
For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then a single real number means the maximal expected number of correctly solved problems if this team follow the best
strategy, to five digits after the decimal point. Look at the output for sample input for details.


Sample Input
1
2 3
0.6 0.3 0.4
0.3 0.7 0.9




Sample Output
Case #1: 2.20000




Source
2014 ACM/ICPC Asia Regional Shanghai Online


题意:ACM比赛规则: 一个队有n个人,一场比赛有m道题,每一道题只能由一个人在一个单位时间内独立完成。在任何一时刻,任意两个人做的题目数量差值不超过1;

思路:仔细思考就会发现,可以把m道题分成若干个n段,每一段都是n的排列求其最大值,状压即可;

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <string>
#include <cstdio>
#include <cmath>
const int N=11;
const int M=1100;
using namespace std;

double p
[M];
double dp[M][1<<N];
int n,m;

void Init()
{
 memset(dp,0,sizeof(dp));
 for(int i=1;i<=n;i++)
   {
    for(int j=1;j<=m;j++)
      scanf("%lf",&p[i][j]);
    dp[1][1<<(i-1)]=p[i][1];
   }
}

int main()
{
    int T,test=1;
    cin>>T;
    while(T--)
    {
     scanf("%d%d",&n,&m);
     Init();
     int top=1<<n;
     for(int i=2;i<=m;i++)
        for(int j=0;j<top;j++)
        {
         if(dp[i-1][j])
         {
          for(int k=1;k<=n;k++)
          {
            int t=(1<<(k-1));
            if(!(j&t))
            {
             int next=j|t;
             if(next==top-1)next=0;
             if(dp[i-1][j]+p[k][i]>dp[i][next])
                dp[i][next]=dp[i-1][j]+p[k][i];
            }
          }
         }
        }
      double maxn=0.0;
      for(int i=0;i<top;i++)
        if(dp[m][i]>maxn)maxn=dp[m][i];
      printf("Case #%d: %.5lf\n",test++,maxn);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: