您的位置:首页 > 其它

hdu----(5050)Divided Land(二进制求最大公约数)

2014-09-27 20:45 369 查看

Divided Land

Time Limit: 8000/4000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 123 Accepted Submission(s): 64


[align=left]Problem Description[/align]

It’s time to fight the local despots and redistribute the land. There
is a rectangular piece of land granted from the government, whose
length and width are both in binary form. As the mayor, you must segment
the land into multiple squares of equal size for the villagers. What
are required is there must be no any waste and each single segmented
square land has as large area as possible. The width of the segmented
square land is also binary.

[align=left]Input[/align]
The first line of the input is T (1 ≤ T ≤ 100), which stands for the number of test cases you need to solve.

Each case contains two binary number represents the length L and the width W of given land. (0 < L, W ≤ 21000)

[align=left]Output[/align]

For each test case, print a line “Case #t: ”(without quotes, t means
the index of the test case) at the beginning. Then one number means the
largest width of land that can be divided from input data. And it will
be show in binary. Do not have any useless number or space.

[align=left]Sample Input[/align]

3
10 100
100 110
10010 1100

[align=left]Sample Output[/align]

Case #1: 10
Case #2: 10
Case #3: 110

二进制求最大公约数:
代码:

#include <stdio.h>
#include <string.h>
#define MAXN 1000
struct BigNumber{
int len;
int v[MAXN];
};
bool isSmaller(BigNumber n1,BigNumber n2)
{
if(n1.len<n2.len)
return 1;
if(n1.len>n2.len)
return 0;
for(int i=n1.len-1;i>=0;i--)
{
if(n1.v[i]<n2.v[i])
return 1;
if(n1.v[i]>n2.v[i])
return 0;
}
return 0;
}
BigNumber minus(BigNumber n1,BigNumber n2)
{
BigNumber ret;
int borrow,i,temp;
ret=n1;
for(borrow=0,i=0;i<n2.len;i++)
{
temp=ret.v[i]-borrow-n2.v[i];
if(temp>=0)
{
borrow=0;
ret.v[i]=temp;
}
else
{
borrow=1;
ret.v[i]=temp+2;
}
}
for(;i<n1.len;i++)
{
temp=ret.v[i]-borrow;
if(temp>=0)
{
borrow=0;
ret.v[i]=temp;
}
else
{
borrow=1;
ret.v[i]=temp+2;
}
}
while(ret.len>=1 && !ret.v[ret.len-1])
ret.len--;
return ret;
}
BigNumber div2(BigNumber n)
{
BigNumber ret;
ret.len=n.len-1;
for(int i=0;i<ret.len;i++)
ret.v[i]=n.v[i+1];
return ret;
}
void gcd(BigNumber n1,BigNumber n2)
{
long b=0,i;
while(n1.len && n2.len)
{
if(n1.v[0])
{
if(n2.v[0])
{
if(isSmaller(n1,n2))
n2=minus(n2,n1);
else
n1=minus(n1,n2);
}
else
n2=div2(n2);
}
else
{
if(n2.v[0])
n1=div2(n1);
else
{
n1=div2(n1);
n2=div2(n2);
b++;
}
}
}
if(n2.len)
for(i=n2.len-1;i>=0;i--)
printf("%d",n2.v[i]);
else
for(i=n1.len-1;i>=0;i--)
printf("%d",n1.v[i]);
while(b--)
printf("0");
printf("\n");
}
int main()
{
int cases,le,i;
BigNumber n1,n2;
char str1[MAXN],str2[MAXN];
scanf("%d",&cases);
for(int w=1;w<=cases;w++)
{
scanf("%s%s",str1,str2);
le=strlen(str1);
n1.len=le;
for(i=0;i<le;i++)
n1.v[i]=str1[le-1-i]-'0';
le=strlen(str2);
n2.len=le;
for(i=0;i<le;i++)
n2.v[i]=str2[le-1-i]-'0';
printf("Case #%d: ",w);
gcd(n1,n2);
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: