您的位置:首页 > 其它

Contest+hdu+状态压缩dp

2014-09-27 20:16 344 查看


Contest

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 0 Accepted Submission(s): 0



Problem Description

In the ACM International Collegiate Programming Contest, each team consist of three students. And the teams are given 5 hours to solve between 8 and 12 programming problems.

On Mars, there is programming contest, too. Each team consist of N students. The teams are given M hours to solve M programming problems. Each team can use only one computer, but they can’t cooperate to solve a problem. At the beginning of the ith hour, they will get the ith programming problem. They must choose a student to solve this problem and others go out to have a rest. The chosen student will spend an hour time to program this problem. At the end of this hour, he must submit his program. This program is then run on test data and can’t modify any more.

Now, you have to help a team to find a strategy to maximize the expected number of correctly solved problems.

For each problem, each student has a certain probability that correct solve. If the ith student solve the jth problem, the probability of correct solve is Pij .

At any time, the different between any two students’ programming time is not more than 1 hour. For example, if there are 3 students and there are 5 problems. The strategy {1,2,3,1,2}, {1,3,2,2,3} or {2,1,3,3,1} are all legal. But {1,1,3,2,3},{3,1,3,1,2} and {1,2,3,1,1} are all illegal.

You should find a strategy to maximize the expected number of correctly solved problems, if you have know all probability


Input

The first line of the input is T (1 ≤ T ≤ 20), which stands for the number of test cases you need to solve.

The first line of each case contains two integers N ,M (1 ≤ N ≤ 10,1 ≤ M ≤ 1000),denoting the number of students and programming problem, respectively.

The next N lines, each lines contains M real numbers between 0 and 1 , the jth number in the ith line is Pij .


Output

For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then a single real number means the maximal expected number of correctly solved problems if this team follow the best strategy, to five digits after the decimal point. Look at the output for sample input for details.


Sample Input

1
2 3
0.6 0.3 0.4
0.3 0.7 0.9


Sample Output

Case #1: 2.20000
解决方案:dp[t][state],t表示第几道题,state表示已做题的人。最多总共只有10个人,可以状态压缩。然后就是题目要求的问题了,m个题目可以把做的题分成几份,没分n题,然后对每分进行dp状态压缩,将其累加。得到最终结果即为答案。code:
#include <iostream>
#include<cstdio>
#include <cstring>
using namespace std;
double p[1003][13];
double dp[13][2000];
int n,m;
int cnt(int k)
{
int c=0;
for(int i=0; i<n; i++)
{
if(k&(1<<i)) c++;
}
return c;
}
int main()
{
int t,y=0;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
for(int i=1; i<=n; i++)
for(int j=1; j<=m; j++)
{
scanf("%lf",&p[j][i]);
}
int len=(1<<n);
double sum=0;
int i=1;
for(; i+n<=m+1; i+=n)
{
memset(dp,0,sizeof(dp));
for(int s=1; s<=n; s++)
for(int k=0; k<len; k++)
{
if(cnt(k)==s-1)
{
for(int j=0; j<n; j++)
if((k&(1<<j))==0)
dp[s][k|(1<<j)]=max(dp[s][k|(1<<j)],dp[s-1][k]+p[i+s-1][j+1]);
}
}
sum+=dp
[len-1];
}
memset(dp,0,sizeof(dp));
double mm=0;
for(int s=1; s<=m-i+1; s++)
{
for(int k=0; k<len; k++)
{
if(cnt(k)==s-1)
{
for(int j=0; j<n; j++)
{
if((k&(1<<j))==0)
dp[s][k|(1<<j)]=max(dp[s][k|(1<<j)],dp[s-1][k]+p[i+s-1][j+1]);
if(dp[s][k|(1<<j)]>mm) mm=dp[s][k|(1<<j)];
}
}
}

}
sum+=mm;
printf("Case #%d: %.5lf\n",++y,sum);
}
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: