您的位置:首页 > 运维架构

HDOJ 题目1299 Diophantus of Alexandria(数学)

2014-09-26 01:10 393 查看

Diophantus of Alexandria

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2444    Accepted Submission(s): 934


[align=left]Problem Description[/align]
Diophantus of Alexandria was an egypt mathematician living in Alexandria. He was one of the first mathematicians to study equations where variables were restricted to integral values. In honor of him, these equations are
commonly called diophantine equations. One of the most famous diophantine equation is x^n + y^n = z^n. Fermat suggested that for n > 2, there are no solutions with positive integral values for x, y and z. A proof of this theorem (called Fermat's last theorem)
was found only recently by Andrew Wiles.

Consider the following diophantine equation: 

1 / x + 1 / y = 1 / n where x, y, n ∈ N+ (1)

Diophantus is interested in the following question: for a given n, how many distinct solutions (i. e., solutions satisfying x ≤ y) does equation (1) have? For example, for n = 4, there are exactly three distinct solutions: 

1 / 5 + 1 / 20 = 1 / 4

1 / 6 + 1 / 12 = 1 / 4

1 / 8 + 1 / 8 = 1 / 4

Clearly, enumerating these solutions can become tedious for bigger values of n. Can you help Diophantus compute the number of distinct solutions for big values of n quickly?

 

[align=left]Input[/align]
The first line contains the number of scenarios. Each scenario consists of one line containing a single number n (1 ≤ n ≤ 10^9). 

 

[align=left]Output[/align]
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Next, print a single line with the number of distinct solutions of equation (1) for the given
value of n. Terminate each scenario with a blank line. 

 

[align=left]Sample Input[/align]

2
4
1260

 

[align=left]Sample Output[/align]

Scenario #1:
3

Scenario #2:
113

 

[align=left]Source[/align]
TUD Programming Contest 2006
 

[align=left]Recommend[/align]
JGShining   |   We have carefully selected several similar problems for you:  1222 1695 1573 1787 3579 
 
ac代码

定理1: 一个正整数 n 可以用素因子唯一表示为 p1^r1 * p2^r2 * ... pk^rk (其中 pi 为素数) , 那么这个数的因子的个数就是,(r1+1)*(r2+1)~(rk+1).
定理2:如果一个数字 n = p1^r1 * p2^r2 * ... pk^rk ,那么 n*n = p1^r1 * p2^r2 * ... pk^rk   * p1^r1 * p2^r2 * ... pk^rk ,它的因子的个数就是 (2*r1+1)*(2*r2+1)~(2*rk+1).
由1/x+1/y=1/n
  简化成(x-n)(y-n)=n*n,
所以求n*n的因子数ans
x,y的组数就是(ans+1)/2
ac代码
#include<stdio.h>
int a[100000],k=0;
void fun()
{
int i,j,w;
k=0;
for(i=2;i<100000;i++)
{
w=1;
for(j=2;j*j<=i;j++)
if(i%j==0)
{
w=0;
break;
}
if(w)
a[k++]=i;
}

}
int main()
{
int t,c=0;
fun();
scanf("%d",&t);
while(t--)
{
int n,ans=1,i,m;
scanf("%d",&n);
m=n;
for(i=0;i<k;i++)
{
int t=0;
if(a[i]*a[i]>m)
{
break;
}
while(n%a[i]==0)
{
n/=a[i];

t++;
}
ans*=(1+t*2);
}
if(n!=1)
ans*=3;
printf("Scenario #%d:\n",++c);
printf("%d\n\n",(ans+1)/2);
}
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: