您的位置:首页 > 其它

[1552]Doubles (纯水题) POJ

2014-09-25 20:29 260 查看
Doubles

Time Limit: 1000MSMemory Limit: 10000K
Description
As part of an arithmetic competency program, your students will be given randomly generated lists of from 2 to 15 unique positive integers and asked
to determine how many items in each list are twice some other item in the same list. You will need a program to help you with the grading. This program should be able to scan the lists and output the correct answer for each one. For example, given the list

1 4 3 2 9 7 18 22


your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9.

Input
The input will consist of one or more lists of numbers. There will be one list of numbers per line. Each list will contain from 2 to 15 unique positive
integers. No integer will be larger than 99. Each line will be terminated with the integer 0, which is not considered part of the list. A line with the single number -1 will mark the end of the file. The example input below shows 3 separate lists. Some lists
may not contain any doubles.
Output
The output will consist of one line per input list, containing a count of the items that are double some other item.
Sample Input
1 4 3 2 9 7 18 22 0
2 4 8 10 0
7 5 11 13 1 3 0
-1

Sample Output
3
2
0

题意:找出一组无重复的数中,若存在两个数为二倍关系,并记录下有多少对二倍关系
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
int main()
{
int a[110];
int sum;
int n=1,i,j,k,t;
while(scanf("%d",&a[0])&&a[0]!=-1)
{
sum=0;
while(scanf("%d",&a[n++]))
{
if(a[n-1]==0)
break;
}
for(i=0; i<n-1; i++)
for(j=0; j<n-i-1; j++)//对这组由小到大数排序(冒泡排序)
if(a[j]>a[j+1])
{
t=a[j];
a[j]=a[j+1];
a[j+1]=t;
}
for(i=0; i<n; i++)
{
for(j=i+1; j<n; j++)
{
if(a[j]==2*a[i])
{
sum++;
break;
}
}
}
printf("%d\n",sum);
n=1;//初始化n的值
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: