您的位置:首页 > 其它

UVA - 10020 Minimal coverage(区间覆盖问题)

2014-09-23 20:41 423 查看



Minimal coverage

The Problem

Given several segments of line (int the X axis) with coordinates [Li,Ri]. You are to choose the minimal amount of them, such they would completely cover the segment [0,M].

The Input

The first line is the number of test cases, followed by a blank line.

Each test case in the input should contains an integer M(1<=M<=5000), followed by pairs "Li Ri"(|Li|, |Ri|<=50000, i<=100000), each on a separate line. Each test case of input is terminated by pair "0 0".

Each test case will be separated by a single line.

The Output

For each test case, in the first line of output your programm should print the minimal number of line segments which can cover segment [0,M]. In the following lines, the coordinates of segments, sorted by their left end (Li), should be printed in
the same format as in the input. Pair "0 0" should not be printed. If [0,M] can not be covered by given line segments, your programm should print "0"(without quotes).

Print a blank line between the outputs for two consecutive test cases.

Sample Input

2

1
-1 0
-5 -3
2 5
0 0

1
-1 0
0 1
0 0


Sample Output

0

1
0 1


题目大意:

输入一个数字m,再输入一组区间,问:能否用最少的区间覆盖[0,m]的区间。

解析:

典型的贪心题,思路按照刘汝佳白书P154页上的解析。

在这里再解释一下

(1)先把区间按照起点从小到大排序,先用一个变量left指向0

|----------------------|

0(left) m

(2)然后遍历所有的线段,取出起点小于left,且终点尽量最大的区间,记录下该区间

(3)然后让left指向该区间的终点,重复(2)的操作,直到left >= m,或者没有线段可以更新为止,结束操作。

|----------|-----------|

0 left m

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <cstdlib>
using namespace std;
typedef long long ll;
const int INF = 0x3f3f3f3f;
const int N = 100005;
struct Segment {
	int l ,r;
}s
, path
;
int n, m, cnt;
bool cmp(Segment a, Segment b) {
	return a.l < b.l;
}
void input() {
	scanf("%d", &m);
	for(n = 0;; n++) {
		scanf("%d%d", &s
.l, &s
.r);
		if(!s
.l && !s
.r) break;
	}
}
bool solve() {
	int left, Max, pos;

	cnt = left = Max = pos = 0;
	for(int i = 0; i < n;) {
		int j = i;
		while(j < n && s[j].l <= left) {
			if(s[j].r > Max) {
				Max = s[j].r;
				pos = j;
			}
			j++;
		}
		if(i == j) break;

		path[cnt].l = s[pos].l;
		path[cnt++].r = s[pos].r;

		left = Max, i = j;

		if(left >= m) return true;
	}
	return false;
}
int main() {
	int T;
	scanf("%d", &T);
	while(T--) {
		input();
		sort(s,s + n, cmp);
		if(s[0].l > 0)
			printf("0\n");
		else if(solve()) {  
			printf("%d\n",cnt);  
			for(int i = 0; i < cnt; i++)  
				printf("%d %d\n",path[i].l,path[i].r);  
		}else
			printf("0\n");  
		
		if(T) puts("");
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: