您的位置:首页 > 理论基础 > 计算机网络

2014亚洲区域赛网络赛广州赛区A Corrupt Mayor's Performance Art(hdoj5023)

2014-09-23 19:32 525 查看


A Corrupt Mayor's Performance Art

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 100000/100000 K (Java/Others)

Total Submission(s): 575    Accepted Submission(s): 229

Problem Description

Corrupt governors always find ways to get dirty money. Paint something, then sell the worthless painting at a high price to someone who wants to bribe him/her on an auction, this seemed a safe way for mayor X to make money.

Because a lot of people praised mayor X's painting(of course, X was a mayor), mayor X believed more and more that he was a very talented painter. Soon mayor X was not satisfied with only making money. He wanted to be a famous painter. So he joined the local
painting associates. Other painters had to elect him as the chairman of the associates. Then his painting sold at better price.

The local middle school from which mayor X graduated, wanted to beat mayor X's horse fart(In Chinese English, beating one's horse fart means flattering one hard). They built a wall, and invited mayor X to paint on it. Mayor X was very happy. But he really had
no idea about what to paint because he could only paint very abstract paintings which nobody really understand. Mayor X's secretary suggested that he could make this thing not only a painting, but also a performance art work.

This was the secretary's idea:

The wall was divided into N segments and the width of each segment was one cun(cun is a Chinese length unit). All segments were numbered from 1 to N, from left to right. There were 30 kinds of colors mayor X could use to paint the wall. They named those colors
as color 1, color 2 .... color 30. The wall's original color was color 2. Every time mayor X would paint some consecutive segments with a certain kind of color, and he did this for many times. Trying to make his performance art fancy, mayor X declared that
at any moment, if someone asked how many kind of colors were there on any consecutive segments, he could give the number immediately without counting.

But mayor X didn't know how to give the right answer. Your friend, Mr. W was an secret officer of anti-corruption bureau, he helped mayor X on this problem and gained his trust. Do you know how Mr. Q did this?

 

Input

There are several test cases.

For each test case:

The first line contains two integers, N and M ,meaning that the wall is divided into N segments and there are M operations(0 < N <= 1,000,000; 0<M<=100,000) 

Then M lines follow, each representing an operation. There are two kinds of operations, as described below: 

1) P a b c 

a, b and c are integers. This operation means that mayor X painted all segments from segment a to segment b with color c ( 0 < a<=b <= N, 0 < c <= 30).

2) Q a b

a and b are integers. This is a query operation. It means that someone asked that how many kinds of colors were there from segment a to segment b ( 0 < a<=b <= N).

Please note that the operations are given in time sequence.

The input ends with M = 0 and N = 0.

 

Output

For each query operation, print all kinds of color on the queried segments. For color 1, print 1, for color 2, print 2 ... etc. And this color sequence must be in ascending order.

 

Sample Input

5 10
P 1 2 3
P 2 3 4
Q 2 3
Q 1 3
P 3 5 4
P 1 2 7
Q 1 3
Q 3 4
P 5 5 8
Q 1 5
0 0

 

Sample Output

4
3 4
4 7
4
4 7 8

 

Source

2014 ACM/ICPC Asia Regional
Guangzhou Online

签到题,线段树带状态压缩。

题目意思是一面墙分成N块,标号1——N,一开始涂2号颜色,题目给你P是说从某一块到某一块涂几号颜色,Q是询问从某一块到某一块有几种颜色,按从小到大的顺序打印出来...

但是没做对,不只是不细心还是感冒折磨的我难受,反正就是没AC,今天做了做,把它A掉了....

#include <stdio.h>
#include <string.h>

int d[4000010];//线段树数组
int lz[4000010];//线段树的lazy数组
bool cl[31];//标记颜色,为了最后输出

void build(int s,int t,int step)//创建线段树
{
lz[step] = 0;
if(s == t)
{
d[step] = 2;//初始化为2
return ;
}
int mid = (s + t) >> 1;
build(s,mid,step << 1);
build(mid + 1,t,step << 1 | 1);
d[step] = d[step << 1];//不用判断,<span style="font-family: Arial, Helvetica, sans-serif;">if(d[step << 1] == d[step << 1 | 1])定然成立,直接回溯就可以了</span>
}

void qu(int s,int t,int qs,int qt,int step)//询问
{
if(qs > t || qt < s)
return ;
if(qs <= s && t <= qt && d[step] != 0)如果不相同,在回溯的时候,我把d[step]设为0,这里显然<span style="font-family: Arial, Helvetica, sans-serif;">d[step]为0必然不成立</span>
{
cl[d[step]] = true;
return ;
}
if(lz[step])//lazy数组下放
{
lz[step << 1] = lz[step];
lz[step << 1 | 1] = lz[step];
d[step << 1] = lz[step];
d[step << 1 | 1] = lz[step];
lz[step] = 0;
}
int mid = (s + t) >> 1;
if(qs <= mid)
{
qu(s,mid,qs,qt,step << 1);
}
if(qt > mid)
{
qu(mid + 1,t,qs,qt,step << 1 | 1);
}
}

void up(int s,int t,int us,int ut,int unum,int step)
{
if(us > t || ut < s)
return ;
if(us <= s && t <= ut)
{
lz[step] = unum;//lazy标记,状态压缩
d[step] = unum;//此时step以下的枝叶必为unum
return ;
}
if(lz[step])//lazy数组下放
{
lz[step << 1] = lz[step];
lz[step << 1 | 1] = lz[step];
d[step << 1] = lz[step];
d[step << 1 | 1] = lz[step];
lz[step] = 0;
}
int mid = (s + t) >> 1;
if(us <= mid)
up(s,mid,us,ut,unum,step << 1);
if(ut > mid)
up(mid + 1,t,us,ut,unum,step << 1 | 1);
if(d[step << 1] == d[step << 1 | 1])//满足左孩子==右孩子,d[step]为非0,反之,为0
d[step] = d[step << 1];
else
d[step] = 0;
}
int main()
{
int s,t,us,ut,unum,qs,qt,m,step;
char str[5];
while(scanf("%d%d",&t,&m),t || m)
{
s = 1;
step = 1;
build(s,t,step);
for(int i = 0;i < m;i++)
{
int j;
scanf("%s",str);
if(str[0] == 'Q')
{
scanf("%d%d",&qs,&qt);
memset(cl,false,sizeof(cl));
qu(s,t,qs,qt,step);
for(j = 1;j < 31;j++)
{
if(cl[j] == true)
{
printf("%d",j);
break;
}
}
for(++j;j < 31;j++)
{
if(cl[j] == true)
{
printf(" %d",j);
}
}
printf("\n");
}
else
{
scanf("%d%d%d",&us,&ut,&unum);
up(s,t,us,ut,unum,step);
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: