您的位置:首页 > 移动开发

HDU 2830 Matrix Swapping II

2014-09-23 15:51 423 查看


Matrix Swapping II

Time Limit: 9000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1260 Accepted Submission(s): 839



Problem Description

Given an N * M matrix with each entry equal to 0 or 1. We can find some rectangles in the matrix whose entries are all 1, and we define the maximum area of such rectangle as this matrix’s goodness.

We can swap any two columns any times, and we are to make the goodness of the matrix as large as possible.



Input

There are several test cases in the input. The first line of each test case contains two integers N and M (1 ≤ N,M ≤ 1000). Then N lines follow, each contains M numbers (0 or 1), indicating the N * M matrix



Output

Output one line for each test case, indicating the maximum possible goodness.



Sample Input

3 4
1011
1001
0001
3 4
1010
1001
0001




Sample Output

4
2

Note: Huge Input, scanf() is recommended.




Source

2009 Multi-University Training Contest 2 - Host
by TJU


解题思路:因为列是可以任意交换的,记录下到当前行为止列的最大的连续1的个数,每行排个序,这样就变成了以当前列为高度的矩形的面积了,然后扫过去更新最大值即可
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define Max 1005
using namespace std;
char matrix[Max][Max];
bool cmp(int a,int b)
{return a>b;}
int main()
{
    int m,n,i,j,h[Max],sum[Max],ans;
    while(~scanf("%d%d",&m,&n))
    {
        ans=0;
        memset(matrix,0,sizeof(matrix));
        memset(h,0,sizeof(h));
        memset(sum,0,sizeof(sum));
        getchar();
        for(i=1;i<=m;i++)
        {
            for(j=1;j<=n;j++)
            {
                scanf("%c",&matrix[i][j]);
                h[j]=matrix[i][j]=='0'?0:h[j]+1;
                sum[j]=h[j];
            }
            getchar();
            sort(sum+1,sum+1+n,cmp);
            for(j=1;j<=n;j++)
                ans=max(ans,sum[j]*j);
            //cout<<ans<<endl;
        }
        printf("%d\n",ans);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: