您的位置:首页 > 编程语言 > Go语言

HDU 4722 Good Numbers

2014-09-23 07:48 288 查看


Good Numbers

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2805 Accepted Submission(s): 885



Problem Description

If we sum up every digit of a number and the result can be exactly divided by 10, we say this number is a good number.

You are required to count the number of good numbers in the range from A to B, inclusive.



Input

The first line has a number T (T <= 10000) , indicating the number of test cases.

Each test case comes with a single line with two numbers A and B (0 <= A <= B <= 1018).



Output

For test case X, output "Case #X: " first, then output the number of good numbers in a single line.



Sample Input

2
1 10
1 20




Sample Output

Case #1: 0
Case #2: 1
Hint
The answer maybe very large, we recommend you to use long long instead of int.




Source

2013 ACM/ICPC Asia Regional Online —— Warmup2

解题思路:数位DP,考虑dp[i][j][k]表示长度为i,首位为j,各个位上数字之和为k的数字个数,具体状态转移见代码

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
long long dp[20][10][10];
void DP()
{
    int i,j,k,p;
    memset(dp,0,sizeof(dp));
    for(i=0;i<10;i++)
        dp[1][i][i]=1;
    for(i=2;i<20;i++)
        for(j=0;j<10;j++)
            for(k=0;k<10;k++)
                for(p=0;p<10;p++)
                    dp[i][j][k]+=dp[i-1][p][(10-j+k)%10];
}
int main()
{
    int t,numa[20],numb[20],i,j,k,p,tmp,n=1;
    _int64 a,b,ansa,ansb;
    bool flag;
    scanf("%d",&t);
    DP();
    while(t--)
    {
        flag=false;
        j=k=tmp=0;
        ansa=ansb=0;
        memset(numa,0,sizeof(numa));
        memset(numb,0,sizeof(numb));
        scanf("%I64d%I64d",&a,&b);
        while(a)
        {
            numa[++j]=a%10;
            a/=10;
            tmp+=numa[j];
        }
        if(tmp%10==0)
        {
            ansa++;
            flag=true;
        }
        tmp=0;
        while(b)
        {
            numb[++k]=b%10;
            b/=10;
            tmp+=numb[k];
        }
        if(tmp%10==0)
            ansb++;
        tmp=0;
        for(i=j;i>0;i--)
        {
            if(tmp==0)
            {
                for(p=0;p<numa[i];p++)
                    ansa+=dp[i][p][0];
            }
            else
            {
                for(p=0;p<numa[i];p++)
                    ansa+=dp[i][p][10-tmp];
            }
            tmp+=numa[i];
            tmp%=10;
        }
        tmp=0;
        for(i=k;i>0;i--)
        {
            if(tmp==0)
            {
                for(p=0;p<numb[i];p++)
                    ansb+=dp[i][p][0];
            }
            else
            {
                for(p=0;p<numb[i];p++)
                    ansb+=dp[i][p][10-tmp];
            }
            tmp+=numb[i];
            tmp%=10;
        }
        if(flag)
            ansb++;
        printf("Case #%d: %I64d\n",n++,ansb-ansa);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: