您的位置:首页 > 理论基础 > 计算机网络

HDU1532/POJ1273 Drainage Ditches 最大排水量 网络最大流 EK、Dinic、ISAP算法

2014-09-23 01:00 316 查看
题目链接:HDU 1532 Drainage Ditches 最大排水量


Drainage Ditches

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 9641 Accepted Submission(s): 4577



Problem Description

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's
clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.

Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.

Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection
1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to
Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10


Sample Output

50


Source

USACO 93

题意:为了不让水淹三叶草,现在修了很多排水管,现在问从源点到汇点的最大排水量。

分析:最大流,EK算法。

代码:

EK:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;

#define maxn 220
#define INF 0x3f3f3f3f
int ans, s, t, n;
int a[maxn], pre[maxn];
int flow[maxn][maxn];
int cap[maxn][maxn];

void Edmonds_Karp()
{
queue<int> q;
memset(flow, 0, sizeof(flow));
ans = 0;
while(1)
{
memset(a, 0, sizeof(a));
a[s] = INF;
q.push(s);
while(!q.empty())   //bfs找增广路径
{
int u = q.front();
q.pop();
for(int v = 1; v <= n; v++)
if(!a[v] && cap[u][v] > flow[u][v])
{
pre[v] = u;
q.push(v);
a[v] = min(a[u], cap[u][v]-flow[u][v]);
}
}
if(a[t] == 0) break;
for(int u = t; u != s; u = pre[u])  //改进网络流
{
flow[pre[u]][u] += a[t];
flow[u][pre[u]] -= a[t];
}
ans += a[t];
}
}

int main()
{
//freopen("hdu_1532.txt", "r", stdin);
int m, u, v, c;
while(~scanf("%d%d", &m, &n))
{
memset(cap, 0, sizeof(cap));
while(m--)
{
scanf("%d%d%d", &u, &v, &c);
cap[u][v] += c;
}
s = 1, t = n;
Edmonds_Karp();
printf("%d\n", ans);
}
return 0;
}


Dinic:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;

#define maxn 220
#define INF 0x3f3f3f3f

struct Edge
{
int from, to, cap;
};

vector<Edge> EG;
vector<int> G[maxn];
int n, s, t, ans, d[maxn], cur[maxn];

void addEdge(int from, int to, int cap)
{
EG.push_back((Edge){from, to, cap});
EG.push_back((Edge){to, from, 0});
int x = EG.size();
G[from].push_back(x-2);
G[to].push_back(x-1);
}

bool bfs()
{
memset(d, -1, sizeof(d));
queue<int> q;
q.push(s);
d[s] = 0;
while(!q.empty())
{
int x = q.front();
q.pop();
for(int i = 0; i < G[x].size(); i++)
{
Edge& e = EG[G[x][i]];
if(d[e.to] == -1 && e.cap > 0)
{
d[e.to] = d[x]+1;
q.push(e.to);
}
}
}
return (d[t]!=-1);
}

int dfs(int x, int a)
{
if(x == t || a == 0) return a;
int flow = 0, f;
for(int& i = cur[x]; i < G[x].size(); i++)
{
Edge& e = EG[G[x][i]];
if(d[x]+1 == d[e.to] && (f = dfs(e.to, min(a, e.cap))) > 0)
{
e.cap -= f;
EG[G[x][i]^1].cap += f;
flow += f;
a -= f;
if(a == 0) break;
}
}
return flow;
}
void Dinic()
{
ans = 0;
while(bfs())
{
memset(cur, 0, sizeof(cur));
ans += dfs(s, INF);
}
}
int main()
{
//freopen("hdu_1532.txt", "r", stdin);
int m, u, v, c;
while(~scanf("%d%d", &m, &n))
{
while(m--)
{
scanf("%d%d%d", &u, &v, &c);
addEdge(u, v, c);
}
s = 1, t = n;
Dinic();
printf("%d\n", ans);
EG.clear();
for(int i = 0; i <= n; ++i)
G[i].clear();
}
return 0;
}


(3)ISAP:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <vector>
using namespace std;

#define maxn 203
#define INF 0x3f3f3f3f

struct Edge
{
int from, to, cap, flow;
};

vector<Edge> EG;
vector<int> G[maxn];
int n, s, t, ans, d[maxn], cur[maxn], p[maxn], num[maxn];
bool vis[maxn];

void addEdge(int from, int to, int cap)
{
EG.push_back((Edge){from, to, cap, 0});
EG.push_back((Edge){to, from, 0, 0});
int x = EG.size();
G[from].push_back(x-2);
G[to].push_back(x-1);
}

void bfs()
{
memset(vis, false, sizeof(vis));
queue<int> q;
vis[t] = true;
d[t] = 0;
q.push(t);
while(!q.empty())
{
int x = q.front();
q.pop();
for(int i = 0; i < G[x].size(); i++)
{
Edge& e = EG[G[x][i]^1];
if(!vis[e.from] && e.cap > e.flow)
{
vis[e.from] = true;
d[e.from] = d[x]+1;
q.push(e.from);
}
}
}
}

int augment()
{
int x = t, a = INF;
while(x != s)
{
Edge& e = EG[p[x]];
a = min(a, e.cap-e.flow);
x = EG[p[x]].from;
}
x = t;
while(x != s)
{
EG[p[x]].flow += a;
EG[p[x]^1].flow -= a;
x = EG[p[x]].from;
}
return a;
}
void ISAP()
{
ans =0;
bfs();
memset(num, 0, sizeof(num));
for(int i = 0; i < n; i++)
num[d[i]]++;
int x = s;
memset(cur, 0, sizeof(cur));
while(d[s] < n)
{
if(x == t)
{
ans += augment();
x = s;
}
bool flag = false;
for(int i = cur[x]; i < G[x].size(); i++)
{
Edge& e = EG[G[x][i]];
if(e.cap > e.flow && d[x] == d[e.to]+1)
{
flag = true;
p[e.to] = G[x][i];
cur[x] = i;
x = e.to;
break;
}
}
if(!flag)
{
int m = n-1;
for(int i = 0; i < G[x].size(); i++)
{
Edge& e = EG[G[x][i]];
if(e.cap > e.flow)
m = min(m, d[e.to]);
}
if(--num[d[x]] == 0) break;
num[d[x] = m+1]++;
cur[x] = 0;
if(x != s)
x = EG[p[x]].from;
}
}
}
int main()
{
//freopen("hdu_1532.txt", "r", stdin);
int m, u, v, c;
while(~scanf("%d%d", &m, &n))
{
while(m--)
{
scanf("%d%d%d", &u, &v, &c);
addEdge(u-1, v-1, c);
}
s = 0, t = n-1;
ISAP();
printf("%d\n", ans);
EG.clear();
for(int i = 0; i < n; ++i)
G[i].clear();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: