您的位置:首页 > 其它

hdu 5038 Grade(简单模拟求解)2014 ACM/ICPC Asia Regional 北京 Online

2014-09-22 08:43 393 查看



Grade

Time Limit: 3000/1500 MS (Java/Others) Memory Limit: 262144/262144
K (Java/Others)



Problem Description

Ted is a employee of Always Cook Mushroom (ACM). His boss Matt gives him a pack of mushrooms and ask him to grade each mushroom according to its weight. Suppose the weight of a mushroom is w, then it’s grade s is

s = 10000 - (100 - w)^2

What’s more, Ted also has to report the mode of the grade of these mushrooms. The mode is the value that appears most often. Mode may not be unique. If not all the value are the same but the frequencies of them are the same, there is no mode.



Input

The first line of the input contains an integer T, denoting the number of testcases. Then T test cases follow.

The first line of each test cases contains one integers N (1<=N<=10^6),denoting the number of the mushroom.

The second line contains N integers, denoting the weight of each mushroom. The weight is greater than 0, and less than 200.



Output

For each test case, output 2 lines.

The first line contains "Case #x:", where x is the case number (starting from 1)

The second line contains the mode of the grade of the given mushrooms. If there exists multiple modes, output them in ascending order. If there exists no mode, output “Bad Mushroom”.



Sample Input

3
6
100 100 100 99 98 101
6
100 100 100 99 99 101
6
100 100 98 99 99 97




Sample Output

Case #1:
10000
Case #2:
Bad Mushroom
Case #3:
9999 10000




开始做这道题时一直在纠结题意,后来看了管理员的回复才终于明白了题意。
题意:用给出的公式求出每个蘑菇的grade,求出现次数最多的grade。如果有多个grade出现的次数一样多,且还有其他的grade,则把这些出现次数最多的grade按升序输出;否则,输出“Bad Mushroom”。

题目并不难,比赛时我用容器写的,浪费了很多内存,代码如下:
#include<cstdio>
#include<cstring>
#include<iostream>
#include<vector>
#include<set>
#include<string>
#include<algorithm>
using namespace std;

vector <int> g[10005];

int fun(int x) {
    return 10000 - (100 - x) * (100 - x);
}

int main()
{
    int n, w, T, cas = 0;
    scanf("%d",&T);
    while(T--) {
        scanf("%d",&n);
        set <int> s;
        memset(g, 0, sizeof(g));
        for(int i = 0; i < n; i++) {
            scanf("%d", &w);
            int grade = fun(w);
            s.insert(grade);
            g[grade].push_back(w);
        }
        set <int> ::iterator it;
        vector <int> v;
        for(it = s.begin(); it != s.end(); it++) {
            v.push_back(g[*it].size());
        }
        sort(v.begin(), v.end());
        int ssize = v.size();
        int cnt = 0;
        for(int i = ssize - 1; i >= 0; i--) {
            if(v[i] == v[ssize-1])
                cnt++;
        }
        printf("Case #%d:\n", ++cas);
        if(cnt == 1) {
            for(it = s.begin(); it != s.end(); it++)
            if(g[*it].size() == v[ssize-1]) {
                printf("%d\n", *it);
                break;
            }
        }

        else {
            if(cnt == ssize)
                printf("Bad Mushroom\n");
            else {
                vector <int> ans;
                for(it = s.begin(); it != s.end(); it++) {
                    int tmp = *it;
                    if(g[tmp].size() == v[ssize-1]) {
                        ans.push_back(tmp);
                    }
                }
                sort(ans.begin(), ans.end());
                int z = ans.size();
                for(int i = 0; i < z - 1; i++)
                    printf("%d ", ans[i]);
                printf("%d\n", ans[z-1]);
            }
        }
    }
    return 0;
}


比赛结束后想了想,因为grade不会超过10000,直接用数组记录出现了哪些grade以及每个grade出现的次数,然后按照题目要求输出即可。
#include<cstdio>
#include<cstring>

const int N = 1e4 + 5;
int cnt
;

int main() {
    int T, n, w, cas = 0;
    scanf("%d",&T);
    while(T--) {
        scanf("%d", &n);
        int S_cnt = 0; //有几个不同的s
        int Max_cnt = 0; //出现次数最多的数出现的次数
        int Max_s = 0, Min_s = 10005; //s的最大最小值
        memset(cnt, 0, sizeof(cnt));
        for(int i = 0; i < n; i++) {
            scanf("%d",&w);
            int s = 10000 - (100 - w) * (100 - w);
            if(s > Max_s) Max_s = s;
            if(s < Min_s) Min_s = s;
            if(!cnt[s]) S_cnt++;
            cnt[s]++;
            if(cnt[s] > Max_cnt) Max_cnt = cnt[s];
        }
        printf("Case #%d:\n", ++cas);
        if(Max_cnt * S_cnt == n && S_cnt > 1)
            printf("Bad Mushroom\n");
        else {
            int p = 0;
            for(int i = Min_s; i <= Max_s; i++) {
                if(cnt[i] == Max_cnt) {
                    if(p) printf(" ");
                    printf("%d", i);
                    p = 1;
                }
            }
            printf("\n");
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐