您的位置:首页 > 其它

HDOJ 5019 Revenge of GCD

2014-09-22 00:24 246 查看
第k大GCD = GCD/第K大因子


Revenge of GCD

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 877    Accepted Submission(s): 259


Problem Description

In mathematics, the greatest common divisor (gcd), also known as the greatest common factor (gcf), highest common factor (hcf), or greatest common measure (gcm), of two or more integers (when at least one of them is not zero), is the largest positive integer
that divides the numbers without a remainder.

---Wikipedia

Today, GCD takes revenge on you. You have to figure out the k-th GCD of X and Y.

 

Input

The first line contains a single integer T, indicating the number of test cases. 

Each test case only contains three integers X, Y and K.

[Technical Specification]

1. 1 <= T <= 100

2. 1 <= X, Y, K <= 1 000 000 000 000

 

Output

For each test case, output the k-th GCD of X and Y. If no such integer exists, output -1.

 

Sample Input

3
2 3 1
2 3 2
8 16 3

 

Sample Output

1
-1
2

 

Source

BestCoder Round #10

 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>

using namespace std;

typedef long long int LL;

LL gcd(LL a,LL b)
{
if(b==0) return a;
return gcd(b,a%b);
}

LL factor[1000100],n;

int main()
{
int T_T;
scanf("%d",&T_T);
while(T_T--)
{
LL x,y,k;
cin>>x>>y>>k;
LL g=gcd(x,y);
LL d=sqrt(g);
n=0;
for(LL i=1;i<=d;i++)
{
if(g%i==0)
{
LL j=g/i;
factor[n++]=i;
if(j!=i) factor[n++]=j;
}
}
sort(factor,factor+n);
if(k>n) puts("-1");
else
{
cout<<g/factor[k-1]<<endl;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: