您的位置:首页 > 其它

POJ 2421 Constructing Roads 修建道路 最小生成树 Kruskal算法

2014-09-19 22:51 363 查看
题目链接:POJ 2421 Constructing Roads 修建道路

Constructing Roads

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 19698Accepted: 8221
Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village
C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village
i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
Sample Input
3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output
179

Source

PKU Monthly,kicc
题意:

有N个村庄,编号从1到N。现需要在这N个村庄之间修路,使得任何两个村庄之间都可以连通。称A、B两个村庄是连通的,当且仅当A与B有路直接连接,或者存在村庄C,使得A和C两村庄之间有路连接,且C和B之间有路连接。已知某些村庄之间已经有路直接连接了,试修建一些路使得所有村庄都是连通的、且修路总长度最短。

分析:

最小生成树问题,已经修好路的村庄之间将他们的长度置为0,然后再用Kruskal算法求解。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

#define maxn 110
#define maxm 5050
int parent[maxn];
int g[maxn][maxn];
int m, ans;

struct edge
{
int u, v, w;
}EG[maxm];
bool cmp(edge a, edge b)
{
return a.w < b.w;
}
int Find(int x)
{
if(parent[x] == -1) return x;
return Find(parent[x]);
}

void Kruskal()
{
memset(parent, -1, sizeof(parent));
ans = 0;
sort(EG, EG+m, cmp);
for(int i = 0; i < m; i++)
{
int t1 = Find(EG[i].u), t2 = Find(EG[i].v);
if(t1 != t2)
{
ans += EG[i].w;
parent[t1] = t2;
}
}
}
int main()
{
int n, q, a, b;
while(~scanf("%d", &n))
{
for(int i = 1; i <= n; i++)
for(int j = 1; j <= n; j++)
scanf("%d", &g[i][j]);
scanf("%d", &q);
while(q--)
{
scanf("%d%d", &a, &b);
g[a][b] = g[b][a] = 0;
}
m = 0;
for(int i = 1; i <= n; i++)
for(int j = i+1; j <= n; j++)
{
EG[m].u = i;
EG[m].v = j;
EG[m].w = g[i][j];
m++;
}
Kruskal();
printf("%d\n", ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: