您的位置:首页 > 其它

poj 3176 -- Cow Bowling

2014-09-19 10:55 399 查看
Cow Bowling

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 13931Accepted: 9230
Description

The cows don't use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this:

7

3   8

8   1   0

2   7   4   4

4   5   2   6   5

Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow's score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame.

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.
Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.
Output

Line 1: The largest sum achievable using the traversal rules
Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30


题目链接:Cow Bowling

思路:简单dp,白皮书入门dp。


/*======================================================================
*           Author :   kevin
*         Filename :   CowBowing.cpp
*       Creat time :   2014-09-18 10:59
*      Description :
========================================================================*/
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <queue>
#include <cmath>
#define clr(a,b) memset(a,b,sizeof(a))
#define M 400
using namespace std;
int s[M][M],dp[M][M];
int main(int argc,char *argv[])
{
int n;
while(scanf("%d",&n)!=EOF){
clr(dp,0);
clr(s,0);
for(int i = 1; i <= n; i++){
for(int j = 1; j <= i; j++){
scanf("%d",&s[i][j]);
}
}
for(int i = 1; i <= n; i++){
dp
[i] = s
[i];
}
for(int i = n-1; i >= 1; i--){
for(int j = 1; j <= i; j++){
dp[i][j] = max(s[i][j] + dp[i+1][j],s[i][j] + dp[i+1][j+1]);
}
}
printf("%d\n",dp[1][1]);
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: