您的位置:首页 > 其它

三分算法学习

2014-09-19 01:47 239 查看
最近学了三分算法,觉得非常神奇!

以下是资料的链接:

http://hi.baidu.com/czyuan_acm/item/81b21d1910ea729c99ce33db

http://blog.csdn.net/rabia/article/details/7826144

http://blog.csdn.net/eastmoon502136/article/details/7706479

三分算法适合凸性函数,我觉得说法不够完美,上凸还是下凸在数学上是指二阶导数小于和大于0的情况,但是这种三分方法不只局限于这种函数吧,比如y=x的绝对值在x等于0处没有导数,但实际上这种函数也符合先减后增的性质。但如果区间既有极大值也有极小值,那么三分就有可能舍弃一些解,从而出错。

以下是一道例题(上凸函数):zoj3203

Light Bulb
Time Limit: 1 Second      Memory Limit: 32768 KB

Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious
house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum
length of his shadow.



Input
The first line of the input contains an integer T (T <= 100), indicating the number of cases.
Each test case contains three real numbers H, h and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is
distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.
Output
For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..
Sample Input

3
2 1 0.5
2 0.5 3
4 3 4


Sample Output

1.000
0.750
4.000


代码:

#include<cstdio>
#include<iostream>
#include<cstring>
#define eps 1e-6
using namespace std;

double H,D,h,lmid,rmid;
double cal(double x){
return D*(h-x)/(H-x)+x;
}
int main()
{
int t;
scanf("%d",&t);
while(t--){
scanf("%lf%lf%lf",&H,&h,&D);
double l=0,r=h;
while(r-l>eps){
lmid=(l+r)/2;
rmid=(lmid+r)/2;
if(cal(lmid)<cal(rmid)) l=lmid;
else r=rmid;
}
printf("%.3f\n",cal(l));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: