您的位置:首页 > 其它

POJ 3067 Japan

2014-09-18 22:02 232 查看
Japan

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 21116Accepted: 5716
Description

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast
are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of
crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.
Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the
East coast and second one is the number of the city of the West coast.
Output

For each test case write one line on the standard output:

Test case (case number): (number of crossings)
Sample Input
1
3 4 4
1 4
2 3
3 2
3 1

Sample Output
Test case 1: 5

Source

Southeastern Europe 2006

解题思路:欲形成交叉点必然是两条线左右高低相反,按点的左侧从大到小排序,保证每次查询的时候都是之前插入的点的右侧大于当前点的右侧,统计其中小于当前点左侧的点的个数就是答案

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[1000005];
struct R
{
	int n;
	int s;
}road[1000005];
int cmp(R a,R b)
{
	if(a.n!=b.n)
		return a.n>b.n;
	else
		return a.s>b.s;
}
int lowbit(int x)
{return x&(-x);}
void add(int pos,int n)
{
	int i;
	for(i=pos;i<=n;i+=lowbit(i))
		a[i]++;
}
int sum(int pos)
{
	int i,sum=0;
	for(i=pos;i>0;i-=lowbit(i))
		sum+=a[i];
	return sum;
}
int main()
{
	int i,j,m,n,k,t;
	long long ans;
	scanf("%d",&t);
	for(i=1;i<=t;i++)
	{
		ans=0;
		memset(a,0,sizeof(a));
		scanf("%d%d%d",&m,&n,&k);
		for(j=1;j<=k;j++)
			scanf("%d%d",&road[j].n,&road[j].s);
		sort(road+1,road+k+1,cmp);
		for(j=1;j<=k;j++)
		{
		    ans+=sum(road[j].s-1);
			add(road[j].s,n);
		}
		cout<<"Test case "<<i<<": "<<ans<<endl;
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: