您的位置:首页 > 其它

poj2488--A Knight's Journey(dfs,骑士问题)

2014-09-18 20:47 393 查看
A Knight's Journey

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 31147 Accepted: 10655
Description


Background 

The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 

around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board,
but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 

Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents
a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares
of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 

If no such path exist, you should output impossible on a single line.
Sample Input
3
1 1
2 3
4 3

Sample Output
Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

Source
TUD Programming Contest 2005, Darmstadt, Germany
给出m行n列的棋盘,问骑士能不能走完所有的点,每个点只能走一次,要求字典序最小输出。
如果能走完,那么一定可以从A1开始走,字典序最小 只要dfsA1开始,看能不能走完,注意搜索的顺序。
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int t , n , m , sum ;
int mm[30][30] ;
int pre[1000] ;
int a[8][2] = { {-2,-1},{-2,1},{-1,-2},{-1,2},{1,-2},{1,2},{2,-1},{2,1} };
int dfs(int x,int y,int temp)
{
if( temp == sum )
return 1 ;
int flag = 0 , xx , yy , i ;
for(i = 0 ; i < 8 ; i++)
{
xx = x + a[i][0] ;
yy = y + a[i][1] ;
if( xx >= 0 && xx < n && yy >= 0 && yy < m && !mm[xx][yy] )
{
mm[xx][yy] = 1 ;
pre[x*m+y] = xx*m+yy ;
flag = dfs(xx,yy,temp+1);
if( flag ) return flag ;
mm[xx][yy] = 0 ;
}
}
return flag ;
}
int main()
{
int i , j , k , tt ;
scanf("%d", &t);
for(tt = 1 ; tt <= t ; tt++)
{
memset(mm,0,sizeof(mm));
memset(pre,-1,sizeof(pre));
scanf("%d %d", &m, &n);
sum = n*m ;
mm[0][0] = 1 ;
k = dfs(0,0,1);
printf("Scenario #%d:\n", tt);
if(k == 0)
printf("impossible");
else
{
for(i = 0 , k = 0 ; i < sum ; i++)
{
printf("%c%c", k/m+'A', k%m+'1');
k = pre[k] ;
}
}
printf("\n\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: