您的位置:首页 > 其它

hdu 2035 人见人爱A^B (快速幂取模)

2014-09-18 20:27 218 查看


人见人爱A^B

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 22492 Accepted Submission(s): 15719



Problem Description

求A^B的最后三位数表示的整数。

说明:A^B的含义是“A的B次方”



Input

输入数据包含多个测试实例,每个实例占一行,由两个正整数A和B组成(1<=A,B<=10000),如果A=0, B=0,则表示输入数据的结束,不做处理。



Output

对于每个测试实例,请输出A^B的最后三位表示的整数,每个输出占一行。



Sample Input

2 3
12 6
6789 10000
0 0




Sample Output

8
984
1



#include<iostream>
#include<cstdio>
using namespace std;

int q_mod(int a,int b)        // 快速幂取模
{
    int s=1;
    while(b>0)
    {
        if(b&1)
            s=a*s%1000;
        a=a*a%1000;
        b=b/2;
    }
    return s;
}

int main()
{
    int a,b;
    int s;
    while(cin>>a>>b,a||b)
    {
        s=q_mod(a,b);
        cout<<s<<endl;
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: