您的位置:首页 > 其它

A Knight's Journey (poj 2488 DFS)

2014-09-18 19:40 633 查看
Language:
Default

A Knight's Journey

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 31142Accepted: 10654
Description


Background

The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey

around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board,
but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem

Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes
how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves
followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.

If no such path exist, you should output impossible on a single line.
Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

Source

TUD Programming Contest 2005, Darmstadt, Germany
题意:给你一个p*q的国际象棋棋盘,问马从任意一点出发能否每个点只经过一次把所有的点都遍历完。其实只需要从最左上角开始走就行了,因为如果每个点都能走到起点在哪就无所谓了。另外要按字典序输出,则dir数组是一定的。最后注意国际象棋行为数字列为字母,开始不小心搞反了一直不对。。。。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 1005
#define MAXN 2005
#define mod 1000000009
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
typedef long long ll;
using namespace std;

struct Node
{
int x,y;
}path[30];

int visit[30][30];
int p,q,step,flag;
int dir[8][2]={-1,-2,1,-2,-2,-1,2,-1,-2,1,2,1,-1,2,1,2};

bool ISok(int x,int y)
{
if (!visit[x][y]&&x>=0&&x<p&&y>=0&&y<q)
return true;
return false;
}

void dfs(int x,int y)
{
if (step==p*q)
{
if (!flag)
{
for (int i=0;i<p*q;i++)
printf("%c%d",path[i].y+'A',path[i].x+1);
printf("\n");
flag=1;
}
return ;
}
for (int i=0;i<8;i++)
{
int dx=x+dir[i][0];
int dy=y+dir[i][1];
if (ISok(dx,dy))
{
visit[dx][dy]=1;
path[step].x=dx;
path[step].y=dy;
step++;
dfs(dx,dy);
visit[dx][dy]=0;
step--;
}
}
}

int main()
{
int Q,cas=1;
scanf("%d",&Q);
while (Q--)
{
scanf("%d%d",&p,&q);
memset(visit,0,sizeof(visit));
printf("Scenario #%d:\n",cas++);
path[0].x=0;
path[0].y=0;
visit[0][0]=1;
step=1;
flag=0;
dfs(0,0);
if (!flag)
printf("impossible\n");
printf("\n");
}
return 0;
}
/*
3 1 1 2 3 4 3
*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: