您的位置:首页 > 其它

hdu 1541(树状数组入门题 Stars)

2014-09-18 15:05 399 查看
题目连接:http://acm.hdu.edu.cn/showproblem.php?pid=1541

Stars

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 4925 Accepted Submission(s): 1948



Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given
star. Astronomers want to know the distribution of the levels of the stars.



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level
0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.


Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one
point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.


Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.


Sample Input
5
1 1
5 1
7 1
3 3
5 5




Sample Output
1
2
1
1
0




Source
Ural Collegiate Programming Contest 1999



Recommend
思路: 因为输入是按y坐标从小到大,当y相同时,按x从小到大,所以可以运用树状数组动态求和的特性
要注意的一点是,对每次输入的x,y坐标都得同时加一,因为树状数组的下标是从1开始的~
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <string>
#include <cstdio>
#include <cmath>
using namespace std;
int c[32100],cnt[15100];
struct node
{
  int x,y;
}a[15100];
int lowbit(int x)
{
   return x&(-x);
}
void update(int x,int n,int d)
{
  while(x<=n)
  {
    c[x]+=d;
    x+=lowbit(x);
  }
}

int getsum(int x)
{
  int ans=0;
  while(x>0)
  {
    ans+=c[x];
    x-=lowbit(x);
  }
  return ans;
}

int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
     memset(c,0,sizeof(c));
     memset(cnt,0,sizeof(cnt));
     int max=-1;
     for(int i=1;i<=n;i++)
     {

      scanf("%d%d",&a[i].x,&a[i].y);
      a[i].x++;
      a[i].y++;
      if(a[i].x>max)max=a[i].x;
     }
     for(int i=1;i<=n;i++)
     {
       cnt[getsum(a[i].x)]++;
       update(a[i].x,max,1);
     }
     for(int i=0;i<n;i++)
     {
       printf("%d\n",cnt[i]);
     }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: