您的位置:首页 > 其它

UVA - 11059 Maximum Product

2014-09-18 13:24 337 查看

Problem D - Maximum Product

Time Limit: 1 second

Given a sequence of integers S = {S1, S2, ..., Sn}, you should determine what is the value of the maximum positive product involving consecutive terms of
S. If you cannot find a positive sequence, you should consider
0
as the value of the maximum product.

Input

Each test case starts with 1 ≤ N ≤ 18, the number of elements in a sequence. Each element
Si is an integer such that -10 ≤ Si ≤ 10. Next line will have
N integers, representing the value of each element in the sequence. There is a blank line after each test case. The input is terminated by end of file (EOF).

Output

For each test case you must print the message: Case #M: The maximum product is P., where
M is the number of the test case, starting from 1, and
P is the value of the maximum product. After each test case you must print a blank line.

Sample Input

3
2 4 -3

5
2 5 -1 2 -1

Sample Output

Case #1: The maximum product is 8.

Case #2: The maximum product is 20.
#include <iostream>
#include <cstdio>
#include <cstring>
#define N 20
using namespace std;

int main() {
int n;
int a
;
int kase = 0;
while (scanf("%d",&n) != EOF) {
if (n == 0)
break;
memset(a,0,sizeof(a));
for (int i = 0; i < n; i++)
scanf("%d",&a[i]);
long long  max = 0;
long long  sum;
for (int i = 0; i < n; i++) {
sum = 1;
for (int j = i ; j < n; j++) {
sum = sum*a[j];
if (sum > max)
max = sum;
}
}
printf("Case #%d: The maximum product is %lld.\n\n", ++kase,max);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  uva UVA - 11059 Maximum