您的位置:首页 > 编程语言 > Go语言

poj3274--Gold Balanced Lineup(hash)

2014-09-16 20:34 295 查看
Gold Balanced Lineup

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 12334 Accepted: 3618
Description

Farmer John's N cows (1 ≤ N ≤ 100,000) share many similarities. In fact, FJ has been able to narrow down the list of features shared by his cows to a list of only K different
features (1 ≤ K ≤ 30). For example, cows exhibiting feature #1 might have spots, cows exhibiting feature #2 might prefer C to Pascal, and so on.

FJ has even devised a concise way to describe each cow in terms of its "feature ID", a single K-bit integer whose binary representation tells us the set of features exhibited by the cow. As an example, suppose a cow has feature ID = 13. Since 13 written
in binary is 1101, this means our cow exhibits features 1, 3, and 4 (reading right to left), but not feature 2. More generally, we find a 1 in the 2^(i-1) place if a cow exhibits feature i.

Always the sensitive fellow, FJ lined up cows 1..N in a long row and noticed that certain ranges of cows are somewhat "balanced" in terms of the features the exhibit. A contiguous range of cows i..j is
balanced if each of the K possible features is exhibited by the same number of cows in the range. FJ is curious as to the size of the largest balanced range of cows. See if you can determine it.

Input
Line 1: Two space-separated integers, N and K. 

Lines 2..N+1: Line i+1 contains a single K-bit integer specifying the features present in cow i. The least-significant bit of this integer is 1 if the cow exhibits feature #1, and the
most-significant bit is 1 if the cow exhibits feature #K.
Output
Line 1: A single integer giving the size of the largest contiguous balanced group of cows.
Sample Input
7 3
7
6
7
2
1
4
2

Sample Output
4

Hint
In the range from cow #3 to cow #6 (of size 4), each feature appears in exactly 2 cows in this range

题目大意,按二进制给出一些特征,求最长的一段内的所有特征相同

首先用p[i][j]存储从第一个牛到底i头牛,关于第j种特征的总数,如果某一段中的[i,j]符合,那么

p[j][0] - p[i-1][0] = p[j][1] = p[i-1][1] = 。。 =  p[j][k-1] - p[i-1][k-1];从第0到k-1所有的差都相同,一定是p[j][0...k] - p[i-1][0...k] 才对应的是区间[i,j];

那么,转化后的p[j][1] - p[j][0] = p[i-1][1] - p[i-1][0] , p[j][2] - p[j][0] = p[i-1][2] - p[i-1][0] 。。。。一直k-1

所以最后是p[i][j]转化为p[i][j] = p[i][j] - p[i][0] ;那么如果区间[i,j]相同,那么p[i-1]和p[j]应该完全相同,使用hash找到最长的一段

注意,存在可能区间[1,n]是最长的区间,所以在vec[0] 中加入0

 

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std ;
#define mod 999997
int p[110000][32] ;
vector <int> vec[100000] ;
int main()
{
int i , j , n , k , a , c[32] , num , flag , l , h , max1 = 0 ;
__int64 sum ;
scanf("%d %d", &n, &k);
for(i = 0 , num = 1; i < k ; i++)
{
p[0][i] = 0 ; num *= 2 ;
}
sum = 0;
vec[0].push_back(0) ;
for(i = 1 ; i <= n ; i++)
{
scanf("%d", &a);
if(a == num-1)
max1 = 1 ;
j = k-1 ;
memset(c,0,sizeof(c));
while(a)
{
c[j--] = a%2 ;
a /= 2 ;
}
for(j = 0 ; j < k ; j++)
{
p[i][j] = p[i-1][j] + c[j] ;
}
}
for(i = 1 ; i <= n ; i++)
{
sum = 0 ;
for(j = 1 ; j < k ; j++)
{
p[i][j] = p[i][j] - p[i][0] ;
sum += p[i][j] ;
}
p[i][0] = 0 ;
if(sum < 0) sum += 100000 ;
sum %= mod ;
num = vec[sum].size();
flag = 0 ;
for(j = 0 ; j < num ; j++)
{
l = vec[sum][j] ;
for(h = 0 ; h < k ; h++)
if( p[i][h] != p[l][h] )
break;
if(h == k)
{
flag = 1 ;
if( max1 < i-l )
max1 = i-l ;
}
}
if(!flag)
vec[sum].push_back(i) ;
}
printf("%d\n", max1);
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: