您的位置:首页 > 产品设计 > UI/UE

Quicksum

2014-09-16 19:17 176 查看

Quicksum

Time Limit: 2000/1000 MS (Java/Others) Memory Limit:
32768/32768 K (Java/Others)
Total Submission(s): 776 Accepted Submission(s): 533
[align=left]Problem Description[/align]
A checksum is an algorithm that scans a packet of data and
returns a single number. The idea is that if the packet is changed,
the checksum will also change, so checksums are often used for
detecting transmission errors, validating document contents, and in
many other situations where it is necessary to detect undesirable
changes in data.

For this problem, you will implement a checksum algorithm called
Quicksum. A Quicksum packet allows only uppercase letters and
spaces. It always begins and ends with an uppercase letter.
Otherwise, spaces and letters can occur in any combination,
including consecutive spaces.

A Quicksum is the sum of the products of each character's position
in the packet times the character's value. A space has a value of
zero, while letters have a value equal to their position in the
alphabet. So, A=1, B=2, etc., through Z=26. Here are example
Quicksum calculations for the packets "ACM" and "MID
CENTRAL":

ACM: 1*1 + 2*3 + 3*13 = 46MID CENTRAL: 1*13 + 2*9 + 3*4 + 4*0 + 5*3
+ 6*5 + 7*14 + 8*20 + 9*18 + 10*1 + 11*12 = 650

[align=left]Input[/align]
The input consists of one or more packets followed by a line
containing only # that signals the end of the input. Each packet is
on a line by itself, does not begin or end with a space, and
contains from 1 to 255 characters.

[align=left]Output[/align]
For each packet, output its Quicksum on a separate line in the
output.

[align=left]Sample Input[/align]

ACM
MID CENTRAL
REGIONAL PROGRAMMING CONTEST
ACN
A C M
ABC
BBC
#


[align=left]Sample Output[/align]

46
650
4690
49
75
14
15

[align=left]Source[/align]
Mid-Central USA 2006

[align=left]Recommend[/align]
teddy
#include<iostream>

#include<stdio.h>

#include<cstring>
using namespace std;

int
main()

{


    
int
i,len,b[1000];

char
a[1000];

while
(gets(a))

{


   
int
s=0;

len=strlen(a);

if
(len==1&&a[0]=='#')

break
;

    
for
(i=0;i<len;i++)

{


   if
(a[i]>='A'&&a[i]<='Z')

   b[i]=a[i]-64;

   else


   b[i]=0;

}


for
(i=0;i<len;i++)

s+=(i+1)*b[i];

cout<<s<<endl;

}

}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: