您的位置:首页 > 其它

hdu 5012 Dice

2014-09-15 21:12 309 查看


Dice

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 440    Accepted Submission(s): 259


Problem Description

There are 2 special dices on the table. On each face of the dice, a distinct number was written. Consider a1.a2,a3,a4,a5,a6 to be numbers written on top face, bottom face, left face, right face,
front face and back face of dice A. Similarly, consider b1.b2,b3,b4,b5,b6 to be numbers on specific faces of dice B. It’s guaranteed that all numbers written on dices are integers no smaller
than 1 and no more than 6 while ai ≠ aj and bi ≠ bj for all i ≠ j. Specially, sum of numbers on opposite faces may not be 7.

At the beginning, the two dices may face different(which means there exist some i, ai ≠ bi). Ddy wants to make the two dices look the same from all directions(which means for all i, ai = bi) only by the following
four rotation operations.(Please read the picture for more information)



Now Ddy wants to calculate the minimal steps that he has to take to achieve his goal.

 

Input

There are multiple test cases. Please process till EOF. 

For each case, the first line consists of six integers a1,a2,a3,a4,a5,a6, representing the numbers on dice A. 

The second line consists of six integers b1,b2,b3,b4,b5,b6, representing the numbers on dice B.

 

Output

For each test case, print a line with a number representing the answer. If there’s no way to make two dices exactly the same, output -1.

 

Sample Input

1 2 3 4 5 6
1 2 3 4 5 6
1 2 3 4 5 6
1 2 5 6 4 3
1 2 3 4 5 6
1 4 2 5 3 6

 

Sample Output

0
3
-1

 

Source

2014 ACM/ICPC Asia Regional Xi'an Online

 

题目及代码:

       直接光搜就可以了,最多搜索到5次就可以了。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;

struct node
{
int s[6];
int step;
}l,r,t,tmp;

queue<node>Q;

bool judge(node t)
{
for(int i=0;i<6;i++)
if(t.s[i]!=r.s[i]) return false;
return true;
}

void left(node &t)
{
int tmp=t.s[3];
t.s[3]=t.s[1];
t.s[1]=t.s[2];
t.s[2]=t.s[0];
t.s[0]=tmp;
}

void right(node &t)
{
int tmp=t.s[0];
t.s[0]=t.s[2];
t.s[2]=t.s[1];
t.s[1]=t.s[3];
t.s[3]=tmp;
}

void front(node &t)
{
int tmp=t.s[5];
t.s[5]=t.s[1];
t.s[1]=t.s[4];
t.s[4]=t.s[0];
t.s[0]=tmp;
}

void back(node &t)
{
int tmp=t.s[0];
t.s[0]=t.s[4];
t.s[4]=t.s[1];
t.s[1]=t.s[5];
t.s[5]=tmp;
}

int bfs()
{
while(!Q.empty())
{
Q.pop();
}
Q.push(l);
while(!Q.empty())
{
t=Q.front();
Q.pop();
if(t.step>=5) break;
if(judge(t)) return t.step;

t.step++;
tmp=t;
right(tmp);
Q.push(tmp);

tmp=t;
left(tmp);
Q.push(tmp);

tmp=t;
front(tmp);
Q.push(tmp);

tmp=t;
back(tmp);
Q.push(tmp);
}
return -1;
}
int main()
{
while(scanf("%d",&l.s[0])!=EOF)
{
l.step=0;
for(int i=1;i<6;i++)
{
scanf("%d",&l.s[i]);
}
for(int i=0;i<6;i++)
{
scanf("%d",&r.s[i]);
}
int n=bfs();
printf("%d\n",n);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: