您的位置:首页 > 其它

hdu 4993(简单枚举或者hash)

2014-09-15 18:34 323 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4993

寻人启事:2014级新生看过来!

Revenge of ex-Euclid

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 273 Accepted Submission(s): 162



Problem Description
In arithmetic and computer programming, the extended Euclidean algorithm is an extension to the Euclidean algorithm, which computes, besides the greatest common divisor of integers a and b, the coefficients of Bézout's identity, that
is integers x and y such that ax + by = gcd(a, b).

---Wikipedia

Today, ex-Euclid takes revenge on you. You need to calculate how many distinct positive pairs of (x, y) such as ax + by = c for given a, b and c.


Input
The first line contains a single integer T, indicating the number of test cases.

Each test case only contains three integers a, b and c.

[Technical Specification]

1. 1 <= T <= 100

2. 1 <= a, b, c <= 1 000 000


Output
For each test case, output the number of valid pairs.


Sample Input
2
1 2 3
1 1 4




Sample Output
1
3




Source
BestCoder Round #9
思路:想多了,直接枚举即可;

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <string>
#include <cstdio>
#include <cmath>
using namespace std;
int main()
{
    int T,a,b,c;
    cin>>T;
    while(T--)
    {
      cin>>a>>b>>c;
      int cnt=0;
      for(int i=1;c-a*i>0;i++)
      {
          if((c-a*i)%b==0)
            cnt++;
      }
      cout<<cnt<<endl;
    }
    return 0;
}
PS:hash也可以做
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: