您的位置:首页 > 理论基础 > 计算机网络

hdu 5012(广搜,西安网络赛)

2014-09-15 18:10 302 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5012

Dice

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 398 Accepted Submission(s): 237



Problem Description
There are 2 special dices on the table. On each face of the dice, a distinct number was written. Consider a1.a2,a3,a4,a5,a6 to be numbers written on top face, bottom
face, left face, right face, front face and back face of dice A. Similarly, consider b1.b2,b3,b4,b5,b6 to be numbers on specific faces of dice B. It’s guaranteed that all numbers written on
dices are integers no smaller than 1 and no more than 6 while ai ≠ aj and bi ≠ bj for all i ≠ j. Specially, sum of numbers on opposite faces may not be 7.

At the beginning, the two dices may face different(which means there exist some i, ai ≠ bi). Ddy wants to make the two dices look the same from all directions(which means for all i, ai = bi) only by the following
four rotation operations.(Please read the picture for more information)



Now Ddy wants to calculate the minimal steps that he has to take to achieve his goal.



Input
There are multiple test cases. Please process till EOF.

For each case, the first line consists of six integers a1,a2,a3,a4,a5,a6, representing the numbers on dice A.

The second line consists of six integers b1,b2,b3,b4,b5,b6, representing the numbers on dice B.


Output
For each test case, print a line with a number representing the answer. If there’s no way to make two dices exactly the same, output -1.


Sample Input
1 2 3 4 5 6
1 2 3 4 5 6
1 2 3 4 5 6
1 2 5 6 4 3
1 2 3 4 5 6
1 4 2 5 3 6




Sample Output
0
3
-1




Source
2014 ACM/ICPC Asia Regional Xi'an Online

思路:操作有四种,枚举这四种操作,直接广搜即可~
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <string>
#include <queue>
#include <algorithm>
using namespace std;
struct node
{
 int a1,a2,a3,a4,a5,a6;
 //int b1,b2,b3,b4,b5,b6;
 int step;
};

int a1,a2,a3,a4,a5,a6;
int b1,b2,b3,b4,b5,b6;
int flag;

char vis[7][7][7][7][7][7];

void bfs()
{
  memset(vis,false,sizeof(vis));
  queue<node>que;

  node cur,next;
  cur.a1=a1;
  cur.a2=a2;
  cur.a3=a3;
  cur.a4=a4;
  cur.a5=a5;
  cur.a6=a6;
  vis[a1][a2][a3][a4][a5][a6]=true;
  cur.step=0;

  que.push(cur);
  while(!que.empty())
  {
    cur=que.front();
    que.pop();
    if(cur.a1==b1&&cur.a2==b2&&cur.a3==b3&&cur.a4==b4&&cur.a5==b5&&cur.a6==b6)
    {
      printf("%d\n",cur.step);
      flag=1;
      return;
    }
    //四个操作分别入队
    //操作一
    next.a1=cur.a4; next.a2=cur.a3; next.a3=cur.a1;
    next.a4=cur.a2; next.a5=cur.a5; next.a6=cur.a6;
    next.step=cur.step+1;
    if(!vis[next.a1][next.a2][next.a3][next.a4][next.a5][next.a6])
    {
       vis[next.a1][next.a2][next.a3][next.a4][next.a5][next.a6]=true;
       que.push(next);
    }
    //操作二
    next.a1=cur.a3; next.a2=cur.a4; next.a3=cur.a2;
    next.a4=cur.a1; next.a5=cur.a5; next.a6=cur.a6;
    next.step=cur.step+1;
    if(!vis[next.a1][next.a2][next.a3][next.a4][next.a5][next.a6])
    {
       vis[next.a1][next.a2][next.a3][next.a4][next.a5][next.a6]=true;
       que.push(next);
    }
    //操作三
    next.a1=cur.a6; next.a2=cur.a5; next.a3=cur.a3;
    next.a4=cur.a4; next.a5=cur.a1; next.a6=cur.a2;
    next.step=cur.step+1;
    if(!vis[next.a1][next.a2][next.a3][next.a4][next.a5][next.a6])
    {
       vis[next.a1][next.a2][next.a3][next.a4][next.a5][next.a6]=true;
       que.push(next);
    }
    //操作四

    next.a1=cur.a5; next.a2=cur.a6; next.a3=cur.a3;
    next.a4=cur.a4; next.a5=cur.a2; next.a6=cur.a1;
    next.step=cur.step+1;
    if(!vis[next.a1][next.a2][next.a3][next.a4][next.a5][next.a6])
    {
       vis[next.a1][next.a2][next.a3][next.a4][next.a5][next.a6]=true;
       que.push(next);
    }

  }
}

int main()
{
    while(scanf("%d%d%d%d%d%d",&a1,&a2,&a3,&a4,&a5,&a6)!=EOF)
    {
        scanf("%d%d%d%d%d%d",&b1,&b2,&b3,&b4,&b5,&b6);
        flag=0;
        bfs();
        if(!flag)
        {
          printf("-1\n");
          continue;
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: