您的位置:首页 > 理论基础 > 计算机网络

hdu 5011 Game(2014 西安网络赛)

2014-09-15 17:56 405 查看


Game

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 258 Accepted Submission(s): 200



Problem Description

Here is a game for two players. The rule of the game is described below:

● In the beginning of the game, there are a lot of piles of beads.

● Players take turns to play. Each turn, player choose a pile i and remove some (at least one) beads from it. Then he could do nothing or split pile i into two piles with a beads and b beads.(a,b > 0 and a + b equals to the number of beads of pile i after removing)

● If after a player's turn, there is no beads left, the player is the winner.

Suppose that the two players are all very clever and they will use optimal game strategies. Your job is to tell whether the player who plays first can win the game.

Input

There are multiple test cases. Please process till EOF.

For each test case, the first line contains a postive integer n(n < 105) means there are n piles of beads. The next line contains n postive integer, the i-th postive integer ai(ai < 231) means there are ai beads
in the i-th pile.

Output

For each test case, if the first player can win the game, ouput "Win" and if he can't, ouput "Lose"

Sample Input

1
1
2
1 1
3
1 2 3


Sample Output

Win
Lose
Lose


博弈论,类似石子游戏,看过的人那么多,直接交了个石子游戏的代码上去,竟然过了。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int main()
{
int n;
while(~scanf("%d",&n))
{
int x,ans=0;
for(int i=1;i<=n;i++)
{
scanf("%d",&x);
ans^=x;
}
if(ans)
printf("Win\n");
else
printf("Lose\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: