您的位置:首页 > 其它

HDU 5003 Osu!(数学题)

2014-09-14 18:59 495 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5003

Problem Description

Osu! is a famous music game that attracts a lot of people. In osu!, there is a performance scoring system, which evaluates your performance. Each song you have played will have a score. And the system will sort all you scores in descending order. After that,
the i-th song scored ai will add 0.95^(i-1)*ai to your total score.

Now you are given the task to write a calculator for this system.



Input

The first line contains an integer T, denoting the number of the test cases.

For each test case, the first line contains an integer n, denoting the number of songs you have played. The second line contains n integers a1, a2, ..., an separated by a single space, denoting the score of each song.

T<=20, n<=50, 1<=ai<=500.



Output

For each test case, output one line for the answer.

Your answers will be considered correct if its absolute error is smaller than 1e-5.



Sample Input

1
2
530 478




Sample Output

984.1000000000




Source

2014 ACM/ICPC Asia Regional Anshan Online

代码如下:

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;

double POW(int n)
{
    double s = 1;
    for(int i = 1; i <= n; i++)
    {
        s*=0.95;
    }
    return s;
}
int main()
{
    int n;
    int t;
    double a[57];
    while(~scanf("%d",&t))
    {
        while(t--)
        {
            scanf("%d",&n);
            for(int i = 1; i <= n; i++)
            {
                scanf("%lf",&a[i]);
            }
            sort(a+1,a+n+1);
            double ans = 0;
            int j = 0;
            for(int i = n; i >= 1; i--)
            {
                ans+=a[i]*POW(j++);
            }
            printf("%.10lf\n",ans);
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: