您的位置:首页 > 其它

POJ 3041-Asteroids(二分匹配_最小点覆盖)

2014-09-14 11:52 375 查看
Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of
the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find
the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space.

* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2


Sample Output

2


Hint

INPUT DETAILS:

The following diagram represents the data, where "X" is an asteroid and "." is empty space:

X.X

.X.

.X.

OUTPUT DETAILS:

Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

题意:在一个N*N的矩阵中 有K个障碍物,你有一个武器 每次使用 可以清除某行 或 某列 的障碍物,但是这种武器非常昂贵,所以你要尽可能少的使用;输出 最少使用多少次武器 可以清除所有的障碍物;
思路:裸的二分匹配匈牙利算法。

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
using namespace std;
int map[510][510];
int vis[510];
int link[510];//记录 与Xi关联的Yi元素 line[Yj] = Xi,0表示未关联
int n;
int dfs(int x)//检验顶点x 是否可以增广
{
int i;
for(i=1;i<=n;i++){//Y中所有顶点 i
if(map[x][i]&&!vis[i]){ //如果顶点i 未被使用,并且x与i有边相连
vis[i]=1;//将顶点i标记
if(link[i]==0||dfs(link[i])){//如果顶点i 没有 被标记的边连接到 x,
//或者 i与X中的顶点link[i]构成的边被标记 但X的顶点link[i]可以增广
link[i]=x;//修改边的标记方式,使顶点t与i构成的边关系被标记;
return 1;//可以增广
}
}
}
return 0;
}
int main()
{
int m,i;
int u,v;
int sum=0;
memset(map,0,sizeof(map));
memset(link,0,sizeof(link));
scanf("%d %d",&n,&m);
for(i=0;i<m;i++){
scanf("%d %d",&u,&v);
map[u][v]=1;
}
for(i=1;i<=n;i++){
memset(vis,0,sizeof(vis));
if(dfs(i))
sum++;
}
printf("%d\n",sum);
return 0;
}



内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: