您的位置:首页 > 其它

HDOJ 题目1061Rightmost Digit(规律)

2014-09-14 01:23 381 查看


Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 32374    Accepted Submission(s): 12441


[align=left]Problem Description[/align]
Given a positive integer N, you should output the most right digit of N^N.

 

[align=left]Input[/align]
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single positive integer N(1<=N<=1,000,000,000).

 

[align=left]Output[/align]
For each test case, you should output the rightmost digit of N^N.

 

[align=left]Sample Input[/align]

2
3
4

 

[align=left]Sample Output[/align]

7
6

Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

 
ac代码

#include<stdio.h>
#include<math.h>
#include<stdlib.h>
int main()
{
int n;int s,a,b,num;
scanf("%d",&n);
while(n--)
{

scanf("%d",&num);
a=num%10;
b=num%4;
if(b==0)
b=4;
printf("%d\n",(int)pow((double)a,b)%10);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: