您的位置:首页 > 其它

HDU - 5001 Walk

2014-09-13 22:24 411 查看
Problem Description
I used to think I could be anything, but now I know that I couldn't do anything. So I started traveling.

The nation looks like a connected bidirectional graph, and I am randomly walking on it. It means when I am at node i, I will travel to an adjacent node with the same probability in the next step. I will pick up the start node randomly (each node in the graph
has the same probability.), and travel for d steps, noting that I may go through some nodes multiple times.

If I miss some sights at a node, it will make me unhappy. So I wonder for each node, what is the probability that my path doesn't contain it.


Input
The first line contains an integer T, denoting the number of the test cases.

For each test case, the first line contains 3 integers n, m and d, denoting the number of vertices, the number of edges and the number of steps respectively. Then m lines follows, each containing two integers a and b, denoting there is an edge between node
a and node b.

T<=20, n<=50, n-1<=m<=n*(n-1)/2, 1<=d<=10000. There is no self-loops or multiple edges in the graph, and the graph is connected. The nodes are indexed from 1.


Output
For each test cases, output n lines, the i-th line containing the desired probability for the i-th node.

Your answer will be accepted if its absolute error doesn't exceed 1e-5.


Sample Input
2
5 10 100
1 2
2 3
3 4
4 5
1 5
2 4
3 5
2 5
1 4
1 3
10 10 10
1 2
2 3
3 4
4 5
5 6
6 7
7 8
8 9
9 10
4 9




Sample Output
0.0000000000
0.0000000000
0.0000000000
0.0000000000
0.0000000000
0.6993317967
0.5864284952
0.4440860821
0.2275896991
0.4294074591
0.4851048742
0.4896018842
0.4525044250
0.3406567483
0.6421630037
题意:给你n个点m条边的无向图
思路:dp[j][d]表示不经过i点,d步后到大j点的概率,枚举i
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;
const int maxn = 55;
const double eps = 1e-8;

int n, m, d;
double dp[maxn][10010];
double ans[maxn]; 
vector<int> map[maxn];

int main() {
	int t, x, y;
	scanf("%d", &t);
	while (t--) {
		scanf("%d%d%d", &n, &m, &d);
		for (int i = 1; i <= n; i++)
			map[i].clear();

		for (int i = 1; i <= m; i++) {
			scanf("%d%d", &x, &y);
			map[x].push_back(y);
			map[y].push_back(x);
		}

		for (int k = 1; k <= n; k++) {
			memset(dp, 0, sizeof(dp));
			for (int i = 1; i <= n; i++)
				dp[i][0] = 1.0 / n;
			for (int i = 0; i < d; i++) {
				for (int j = 1; j <= n; j++) {
					if (j == k)
						continue;
					int size = map[j].size();
					for (int l = 0; l < size; l++) {
						int u = map[j][l];
						dp[u][i+1] += dp[j][i] * 1.0 / size;
					}
				}
			}
			ans[k] = 0.0;
			for (int i = 1; i <= n; i++) 
				if (i != k)
					ans[k] += dp[i][d];
			printf("%.10f\n", ans[k]);
		}
	}
	return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: