您的位置:首页 > 其它

HDU 1358 Period

2014-09-13 20:37 323 查看

Period

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 3126 Accepted Submission(s): 1567



Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the
largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.



Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line,
having the number zero on it.



Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the
prefix sizes must be in increasing order. Print a blank line after each test case.



Sample Input
3
aaa
12
aabaabaabaab
0




Sample Output
Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4


解题思路:找出所有前缀的循环节并输出
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#define Max 1000005
using namespace std;
char str[Max];
int Next[Max];
void get_next(char *T,int len)
{
    int j=0,k=-1;
    Next[0]=-1;
    while(j<=len)
    {
        if(k==-1||T[j]==T[k])
        {
            j++;k++;
            Next[j]=k;
        }
        else
            k=Next[k];
    }
}
int main()
{
    int t,ncase=1,i;
    while(scanf("%d",&t),t)
    {
        getchar();
        scanf("%s",str);
        str[t]='\0';
        get_next(str,t);
        printf("Test case #%d\n",ncase++);
        for(i=0;i<t;i++)
        {
            int len0=(i+1)-Next[i+1];
            if((i+1)%len0==0&&len0!=(i+1))
                printf("%d %d\n",i+1,(i+1)/len0);
        }
        printf("\n");
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: