您的位置:首页 > 理论基础 > 计算机网络

2014鞍山网络赛 E题||hdu 5001 概率dp

2014-09-13 20:19 369 查看
http://acm.hdu.edu.cn/showproblem.php?pid=5001

Problem Description

I used to think I could be anything, but now I know that I couldn't do anything. So I started traveling.

The nation looks like a connected bidirectional graph, and I am randomly walking on it. It means when I am at node i, I will travel to an adjacent node with the same probability in the next step. I will pick up the start node randomly (each node in the graph
has the same probability.), and travel for d steps, noting that I may go through some nodes multiple times.

If I miss some sights at a node, it will make me unhappy. So I wonder for each node, what is the probability that my path doesn't contain it.

 

Input

The first line contains an integer T, denoting the number of the test cases.

For each test case, the first line contains 3 integers n, m and d, denoting the number of vertices, the number of edges and the number of steps respectively. Then m lines follows, each containing two integers a and b, denoting there is an edge between node
a and node b.

T<=20, n<=50, n-1<=m<=n*(n-1)/2, 1<=d<=10000. There is no self-loops or multiple edges in the graph, and the graph is connected. The nodes are indexed from 1.

 

Output

For each test cases, output n lines, the i-th line containing the desired probability for the i-th node.

Your answer will be accepted if its absolute error doesn't exceed 1e-5.

 

Sample Input

2
5 10 100
1 2
2 3
3 4
4 5
1 5
2 4
3 5
2 5
1 4
1 3
10 10 10
1 2
2 3
3 4
4 5
5 6
6 7
7 8
8 9
9 10
4 9

 

Sample Output

0.0000000000
0.0000000000
0.0000000000
0.0000000000
0.0000000000
0.6993317967
0.5864284952
0.4440860821
0.2275896991
0.4294074591
0.4851048742
0.4896018842
0.4525044250
0.3406567483
0.6421630037

 

虽然我不会概率dp并且水平还远远没到在比赛的时候可以A出这道题来。。不过在学长的指点之下还是在比赛之后把这个题个过了。。

解题思路:  dp[i][j][k]表示,i代表当前  第i步,j代表当前走到第j个节点,k是没有路过k,整体是  走到第i步恰好在j节点,这个过程中没有路过k的概率 

#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;

double a[3][55][55],ans[55];
int mp[55][55],cnt[55];
int T,n,m,d;

int main()
{
scanf("%d",&T);
while(T--)
{
scanf("%d%d%d",&n,&m,&d);
memset(mp,0,sizeof(mp));
memset(a,0,sizeof(a));
memset(cnt,0,sizeof(cnt));
for(int i=0; i<m; i++)
{
int u,v;
scanf("%d%d",&u,&v);
mp[u][v]=mp[v][u]=1;
cnt[u]++;
cnt[v]++;
}
for(int i=1; i<=n; i++)
for(int j=1; j<=n; j++)
if(i!=j)
a[1][i][j]=1.0/n;
else
a[1][i][j]=0;
for(int i=1; i<=d; i++)
{
memset(a[(i+1)%2],0,sizeof(a[(i+1)%2]));
for(int j=1; j<=n; j++)
for(int k=1; k<=n; k++)
if(mp[j][k])
for(int p=1; p<=n; p++)
if(k!=p)
a[(i+1)%2][k][p]+=a[i%2][j][p]*(1.0/cnt[j]);
else
a[(i+1)%2][k][p]=0;
}
for(int i=1;i<=n;i++)
{
ans[i]=0;
for(int j=1;j<=n;j++)
ans[i]+=a[(d+1)%2][j][i];
}
for(int i=1;i<=n;i++)
printf("%.10lf\n",ans[i]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: