您的位置:首页 > 其它

hdu 3496 Watch The Movie(01背包)

2014-09-13 00:54 387 查看


Watch The Movie

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 65535/65535 K (Java/Others)

Total Submission(s): 5686 Accepted Submission(s): 1804



Problem Description

New semester is coming, and DuoDuo has to go to school tomorrow. She decides to have fun tonight and will be very busy after tonight. She like watch cartoon very much. So she wants her uncle to buy some movies and watch with her tonight. Her grandfather gave
them L minutes to watch the cartoon. After that they have to go to sleep.

DuoDuo list N piece of movies from 1 to N. All of them are her favorite, and she wants her uncle buy for her. She give a value Vi (Vi > 0) of the N piece of movies. The higher value a movie gets shows that DuoDuo likes it more. Each movie has a time Ti to play
over. If a movie DuoDuo choice to watch she won’t stop until it goes to end.

But there is a strange problem, the shop just sell M piece of movies (not less or more then), It is difficult for her uncle to make the decision. How to select M piece of movies from N piece of DVDs that DuoDuo want to get the highest value and the time they
cost not more then L.

How clever you are! Please help DuoDuo’s uncle.

Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by input data for each test case:

The first line is: N(N <= 100),M(M<=N),L(L <= 1000)

N: the number of DVD that DuoDuo want buy.

M: the number of DVD that the shop can sale.

L: the longest time that her grandfather allowed to watch.

The second line to N+1 line, each line contain two numbers. The first number is the time of the ith DVD, and the second number is the value of ith DVD that DuoDuo rated.

Output

Contain one number. (It is less then 2^31.)

The total value that DuoDuo can get tonight.

If DuoDuo can’t watch all of the movies that her uncle had bought for her, please output 0.

Sample Input

1
3 2 10
11 100
1 2
9 1


Sample Output

3


给出n张碟片,选m张,要在l时间内,求价值最大。
二维背包,很容易看出来,这题的wa点在,只能选m张,不能多也不能少,想了很久都没想到怎么处理,看别人的题解,才明白,可以给数组赋初值为一个大负数,这样,选一个只会有dp[1]与dp[0]有联系,是非负数,两个时dp[2]为非负数.....这样就保证了选m张。
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;
const int maxn=1000+100;
int dp[105][maxn];
int main()
{
int n,m,l;
int ca;
scanf("%d",&ca);
while(ca--)
{
scanf("%d%d%d",&n,&m,&l);
memset(dp[0],0,sizeof(dp[0]));
for(int i=1;i<=m;i++)
for(int j=0;j<=l;j++)
{
dp[i][j]=-99999999;
}
int t, v;
for(int i=1;i<=n;i++)
{
scanf("%d%d",&t,&v);
for(int j=m;j>=1;j--)
{
for(int k=l;k>=t;k--)
{
dp[j][k]=max(dp[j][k],dp[j-1][k-t]+v);
printf("%d ",dp[j][k]);
}
printf("\n");
}
}
if(dp[m][l]<0)
{
dp[m][l]=0;
}
printf("%d\n",dp[m][l]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: