您的位置:首页 > 其它

hdu 1031 Design T-Shirt

2014-09-09 22:25 405 查看


Design T-Shirt

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5921 Accepted Submission(s): 2768



Problem Description

Soon after he decided to design a T-shirt for our Algorithm Board on Free-City BBS, XKA found that he was trapped by all kinds of suggestions from everyone on the board. It is indeed a mission-impossible to have everybody perfectly satisfied. So he took a poll
to collect people's opinions. Here are what he obtained: N people voted for M design elements (such as the ACM-ICPC logo, big names in computer science, well-known graphs, etc.). Everyone assigned each element a number of satisfaction. However, XKA can only
put K (<=M) elements into his design. He needs you to pick for him the K elements such that the total number of satisfaction is maximized.

Input

The input consists of multiple test cases. For each case, the first line contains three positive integers N, M and K where N is the number of people, M is the number of design elements, and K is the number of elements XKA will put into his design. Then N lines
follow, each contains M numbers. The j-th number in the i-th line represents the i-th person's satisfaction on the j-th element.

Output

For each test case, print in one line the indices of the K elements you would suggest XKA to take into consideration so that the total number of satisfaction is maximized. If there are more than one solutions, you must output the one with minimal indices. The
indices start from 1 and must be printed in non-increasing order. There must be exactly one space between two adjacent indices, and no extra space at the end of the line.

Sample Input

3 6 4
2 2.5 5 1 3 4
5 1 3.5 2 2 2
1 1 1 1 1 10
3 3 2
1 2 3
2 3 1
3 1 2


Sample Output

6 5 3 1
2 1


n个人给m个物品打分,找出前k个分值高的物品的序号,如果有多组则输出序号和最小的组.

#include <iostream>
#include <cstdlib>
#include <algorithm>
using namespace std;
struct node
{
double score;
int NO;
};
int cmp(const void *a1,const void *b1)
{
node *a=(node*)a1;
node *b=(node*)b1;
return b->score-a->score;
}
int main()
{
int n,m,k;
node num[300];
while (scanf("%d%d%d",&n,&m,&k)!=EOF)
{
for (int i=0; i<m; i++)
{
num[i].score=0;
}
for (int i=0; i<n; i++)
{
double a;
for (int j=0; j<m; j++)
{
scanf("%lf",&a);
num[j].score+=a;
num[j].NO=j+1;
}
}
qsort(num, m, sizeof(num[0]),cmp);
int ans[300];
for (int i=0; i<k; i++)
{
ans[i]=num[i].NO;
}
sort(ans, ans+k, greater<int>());
for (int i=0;i<k-1; i++)
{
cout<<ans[i]<<" ";
}
cout<<ans[k-1]<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: