您的位置:首页 > 其它

HDU 1390 Binary Numbers(数学题)

2014-09-09 15:14 447 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1390

Problem Description

Given a positive integer n, find the positions of all 1's in its binary representation. The position of the least significant bit is 0.

Example

The positions of 1's in the binary representation of 13 are 0, 2, 3.

Task

Write a program which for each data set:

reads a positive integer n,

computes the positions of 1's in the binary representation of n,

writes the result.



Input

The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.

Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.



Output

The output should consists of exactly d lines, one line for each data set.

Line i, 1 <= i <= d, should contain increasing sequence of integers separated by single spaces - the positions of 1's in the binary representation of the i-th input number.



Sample Input

1
13




Sample Output

0 2 3




Source

Central Europe 2001, Practice

题意:

找一个数的二进制中为1的位置!

代码如下:

#include <cstdio>
int a[1000007];
int main()
{
    int n;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        int k = 0;
        int l = -1;
        while(n)
        {
            int t = n%2;
            if(t)
            {
                a[++l] = k;
            }
            k++;
            n/=2;
        }
        for(int i = 0; i < l; i++)
        {
            printf("%d ",a[i]);
        }
        printf("%d\n",a[l]);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: