您的位置:首页 > 其它

杭电1150 Machine Schedule(匈牙利算法模板)

2014-09-08 16:16 246 查看

Machine Schedule

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5872 Accepted Submission(s): 2957



Problem Description
As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type
of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine
B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to
a suitable machine, please write a program to minimize the times of restarting machines.



Input
The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs,
each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.



Output
The output should be one integer per line, which means the minimal times of restarting machine.



Sample Input
5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0




Sample Output
3[code]/*
看了半天KM算法没看明白,找了一道匈牙利算法做一下
最少点覆盖=最大匹配数
*/
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX=110;
int uN,vN;//u v 数目
bool map[MAX][MAX];
int linker[MAX];
bool vis[MAX];
int N,M,K;
bool dfs(int u){
	for(int v=1;v<=M;v++){
		if(!vis[v]&&map[u][v]){
			vis[v]=true;
			if(linker[v]==-1||dfs(linker[v])){
				linker[v]=u;
				return true;
			}
		}
	}
	return false;
}
int hungary(){
	int ans=0;
	memset(linker,-1,sizeof(linker));
	for(int u=1;u<=N;u++){
		memset(vis,0,sizeof(vis));
		if(dfs(u))
			ans++;
	}
	return ans;
}
void solve(){
	while(scanf("%d",&N)!=EOF,N){
		scanf("%d%d",&M,&K);
		int i,u,v;
		memset(map,0,sizeof(map));
		while(K--){
			scanf("%d%d%d",&i,&u,&v);
			map[u][v]=1;
		}
		printf("%d\n",hungary());
	}
}
int main(){
	solve();
	return 0;
}

[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: