您的位置:首页 > Web前端

hdu 1015 Safecracker

2014-09-08 13:56 295 查看


Safecracker

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 8611 Accepted Submission(s): 4347



Problem Description

=== Op tech briefing, 2002/11/02 06:42 CST ===

"The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein's secrets and
wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters,
usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing
the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, ..., Z=26). The combination is then
vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary."

v - w^2 + x^3 - y^4 + z^5 = target

"For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode
the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn't exist then."

=== Op tech directive, computer division, 2002/11/02 12:30 CST ===

"Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations. Input consists of one or more lines containing a positive integer target less than twelve million, a space, then
at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input. For each line output the Klein combination, break ties with lexicographic order, or 'no solution'
if there is no correct combination. Use the exact format shown below."

Sample Input

1 ABCDEFGHIJKL
11700519 ZAYEXIWOVU
3072997 SOUGHT
1234567 THEQUICKFROG
0 END


Sample Output

LKEBA
YOXUZ
GHOST
no solution


就是给定一个目标值target,再给你一个备选字符串(5~12个字符),要你在这个字符串里选5个出来,满足题中给定的等式,并且你选择的这5个字符组成的字符串必须是所有可能情况中按字典序最大的情况。

现将字符串进行排序,然后再进行筛选,这样第一次筛选出来的就是字典序最大的。

#include<iostream>
#include <string.h>
#include <algorithm>
using namespace std;
int flag;
long long t;
int visit[20];
int a[6];
int cmp(char a,char b)
{
return a>b;
}
bool judge(int v,int w,int x,int y,int z)
{
if(v - w*w + x*x*x - y*y*y*y + z*z*z*z*z == t)
return true;
return false;
}
void DFS(char *s,int n)
{
if(n==5)   //判断刚刚递归的5个数是否符合要求
{
if(judge(a[0],a[1],a[2],a[3],a[4]))
{
flag=1;  //标记,不再搜索
}
return;
}
for (int i=0; i<strlen(s); i++)
{
if(!visit[i] && !flag)
{
visit[i]=1;
a
=s[i]-'A'+1;  //转换为数字进行判断
DFS(s, n+1);    //搜索下一个数字
visit[i]=0;   //回溯
}
}
}
int main()
{
char s[15];
while (cin>>t>>s)
{
flag=0;
memset(visit, 0, sizeof(visit));
if(strcmp(s, "END")==0 && t==0)
{
break;
}
sort(s, s+strlen(s), cmp);
DFS(s, 0);
if(flag)
{
for (int i=0; i<5; i++)
{
cout<<(char)(a[i]+'A'-1);
}
}
else
{
cout<<"no solution";
}
cout<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: