您的位置:首页 > 其它

poj 2769 Reduced ID Numbers

2014-09-08 10:38 381 查看
Reduced ID Numbers

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 8968Accepted: 3604
Description

T. Chur teaches various groups of students at university U. Every U-student has a unique Student Identification Number (SIN). A SIN s is an integer in the range 0 ≤ s ≤ MaxSIN with MaxSIN = 106-1. T. Chur finds this range of SINs too large for identification
within her groups. For each group, she wants to find the smallest positive integer m, such that within the group all SINs reduced modulo m are unique.
Input

On the first line of the input is a single positive integer N, telling the number of test cases (groups) to follow. Each case starts with one line containing the integer G (1 ≤ G ≤ 300): the number of students in the group. The following G lines each contain
one SIN. The SINs within a group are distinct, though not necessarily sorted.
Output

For each test case, output one line containing the smallest modulus m, such that all SINs reduced modulo m are distinct.
Sample Input
2
1
124866
3
124866
111111
987651

Sample Output
1
8


#include<iostream>

#include<cstdio>

#include<cstdlib>

#include<cstring>

#include<algorithm>

#include<vector>

#include<stack>

#include<queue>

#include<set>

#include<map>

#include<cmath>

using namespace std;

typedef long long LL;

const int MAX=0xfffffff;

const int mx=1000010;

bool is[mx/10]; //重要的优化,不太理解为什么可以确定ans<100000;

int a[mx];

int main( )

{

freopen("1.txt","r",stdin);

int t;

scanf("%d",&t);

while(t--)

{

int n;

scanf("%d",&n);

for(int i=1;i<=n;i++)

scanf("%d",&a[i]);

int i;

for(i=1;;i++)

{

bool flag=1;

memset(is,0,sizeof(is));

for(int j=1;j<=n;j++)

{

if(is[a[j]%i]==1)

{

flag=0;

break;

}

is[a[j]%i]=1;

}

if(flag==1)

break;

}

printf("%d\n",i);

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: