您的位置:首页 > 其它

hdu 4989 Summary(BestCoder Round #8 1001)

2014-09-07 23:14 363 查看


Summary

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 76 Accepted Submission(s): 53



Problem Description

Small W is playing a summary game. Firstly, He takes N numbers. Secondly he takes out every pair of them and add this two numbers, thus he can get N*(N - 1)/2 new numbers. Thirdly he deletes the repeated number of the new numbers. Finally he gets the sum of
the left numbers. Now small W want you to tell him what is the final sum.

Input

Multi test cases, every case occupies two lines, the first line contain n, then second line contain n numbers a1, a2, ……an separated by exact one space. Process to the end of file.

[Technical Specification]

2 <= n <= 100

-1000000000 <= ai <= 1000000000

Output

For each case, output the final sum.

Sample Input

4
1 2 3 4
2
5 5


Sample Output

25
10
HintFirstly small W takes any pair of 1 2 3 4 and add them, he will get 3 4 5 5 6 7. Then he deletes the repeated numbers, he will get 3 4 5 6 7, Finally he gets the sum=3+4+5+6+7=25.


水题,数据太小,set判重

代码:

//15ms
#include <iostream>
#include <cstdio>
#include <cstring>
#include <set>
using namespace std;
long long a[100];
set<long long> s;
set<long long>::iterator it;
int main()
{
int n;
while(~scanf("%d",&n))
{
for(int i=0;i<n;i++)
{
scanf("%I64d",&a[i]);
}
s.clear();
for(int j=0;j<n-1;j++)
{
for(int k=j+1;k<n;k++)
{
s.insert(a[j]+a[k]);
}
}
long long ans=0;
for(it=s.begin();it!=s.end();it++)
{
ans=ans+*it;
}
printf("%I64d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: