您的位置:首页 > 其它

zoj 1002 Fire Net (简单dfs)

2014-09-07 21:22 537 查看
Fire Net

Time Limit: 2 Seconds Memory Limit: 65536 KB

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.
A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting
through each opening.
Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.
The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided
that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.
The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures
show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.



Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a
positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces
in the input file.
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.
Sample input:
4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

Sample output:
5
1
5
2
4


给你一个带有墙(黑色方块)的棋盘,问你最多可以放多少黑点,前提:黑点不能放在同一行或同一列,除非中间有黑色方块,简单dfs,直接上代码:

#include<stdio.h>
#include<string.h>
#include<cstdio>
#include<iostream>
#define N 1002
using namespace std;
int a

;
int ans;
int n;
bool legal(int x,int y)//判断此点是否能放
{
int i;
if(a[x][y])return false;//不等于0就不能放
if(x>0)//看看上边能不能放,下边类似
{
for(i=x-1;i>=1;i--)
if(a[i][y]==2)break;//有墙就可以
else if(a[i][y])return false;//有点就不行
}
if(x<n)
{
for(i=x+1;i<=n;i++)
if(a[i][y]==2)break;
else if(a[i][y])return false;
}
if(y>0)
{
for(i=y-1;i>=1;i--)
if(a[x][i]==2)break;
else if(a[x][i])return false;
}
if(y<n)
{
for(i=y+1;i<=n;i++)
if(a[x][i]==2)break;
else if(a[x][i])return false;
}
return true;
}
void dfs(int m)//m代表深度,即放的个数
{
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
if(legal(i,j))//能放
{
a[i][j]=1;//放
dfs(m+1);//搜索
a[i][j]=0;//搜索完了搞回来
}
}
}
ans=(ans>m?ans:m);//取最大m
}
int main()
{
char ch;
while(scanf("%d",&n),n)
{
memset(a,0,sizeof(a));
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
cin>>ch;
if(ch=='X')a[i][j]=2;
}
}
ans=0;
dfs(0);
cout<<ans<<endl;
}
}[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: