您的位置:首页 > 产品设计 > UI/UE

poj 1122 FDNY to the Rescue!

2014-09-06 23:37 357 查看
FDNY to the Rescue!

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 2505 Accepted: 768
Description

The Fire Department of New York (FDNY) has always been proud of their response time to fires in New York City, but they want to make their response time even better. To help them with their response time, they want to make sure that the dispatchers know the
closest firehouse to any address in the city. You have been hired to write this software and are entrusted with maintaining the proud tradition of FDNY. Conceptually, the software will be given the address of the fire, the locations of the firehouses, street
intersections, and the time it takes to cover the distance between each intersection. It will then use this information to calculate how long it takes to reach an address from each firehouse. 

Given a specific fire location in the city, the software will calculate the time taken from all the fire stations located in the city to reach the fire location. The list of fire stations will be sorted from shortest time to longest time. The dispatcher can
then pick the closest firestation with available firefighters and equipment to dispatch to the fire.
Input

Line 1: 

# of intersections in the city, a single integer (henceforth referred to as N) N<20 

Lines 2 to N+1: 

A table (square matrix of integer values separated by one or more spaces) representing the time taken in minutes between every pair of intersections in the city. In the sample input shown below the value "3" on the 1st row and the 2nd column represents the
time taken from intersection #1 to reach intersection #2. 

Similarly the value "9" on the 4th row and the 2nd column represents the time taken from intersection #4 to reach intersection #2. 

A value of -1 for time means that it is not possible to go directly from the origin intersection (row #) to the destination intersection (column #). All other values in the table are non-negative. 

Line N+2: 

An integer value n (<= N) indicating the intersection closest to the fire location followed by one or more integer values for the intersections closest to the fire stations (all on one line, separated by one or more spaces) will follow the input matrix. 

Notes on input format: 

1. The rows and columns are numbered from 1 to N. 

2. All input values are integers 

3. All fire locations are guaranteed reachable from all firehouses. 

4. All distance calculations are made from the intersection closest to each firehouse to the intersection closest to the fire. 

Output

Line 1: 

A label line with the headings for each column, exactly as shown in the example. 

Line 2 onwards (one line for each fire station): 

A sorted list (based on time) showing the fire station (origin), the destination site, time taken and a complete shortest path of nodes from the originating fire station to the fire location. 

Notes on output format: 

1. Columns are tab separated. 

2. If two or more firehouses are tied in time they can be printed in any order. 

3. If more than one path exists that has the same minimal time for a given location & firehouse, either one can be printed on the output. 

4. If the fire location and the fire station locations happen to be the same intersection, the output will indicate that the origin and destination have the same intersection number, the time will be "0" and the nodes in the shortest path will show just one
number, the fire location. 

Next is the picture for the sample input data. 



Sample Input
6
0  3  4 -1 -1 -1
-1 0  4  5 -1 -1
2  3  0 -1 -1  2
8  9  5  0  1 -1
7  2  1 -1  0 -1
5 -1  4  5  4  0
2  4  5  6
In the above input the last line indicates that "2" is the location of the fire and "4", "5" and "6" are the intersections where fire stations are located.

Sample Output
Org	Dest	Time	Path
5	2	2	5	2
4	2	3	4	5	2
6	2	6	6	5	2


别看这题描述和输入输出这么复杂,实际上就是一道很裸的dijkstra,给定一个终点,然后和若干起点,求各起点到终点的最短路,还需打印路径。

代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#define Maxn 30
using namespace std;

struct event{
int id,lowcost,path[30],sz;
event():sz(0){}
bool operator<(const event &a)const{
return lowcost<a.lowcost;
}
}p[Maxn];
int adj[Maxn][Maxn];
int x[Maxn],dist[Maxn],vis[Maxn],pre[Maxn];
const int inf=0x3f3f3f3f;
void dijkstra(int u,int n){
for(int i=1;i<=n;i++)
dist[i]=adj[u][i],vis[i]=0,pre[i]=u;
vis[u]=1,pre[u]=-1;
for(int i=1;i<n;i++){
int minn=inf,v;
for(int j=1;j<=n;j++)
if(!vis[j]&&dist[j]<minn)
minn=dist[j],v=j;
vis[v]=1;
for(int j=1;j<=n;j++)
if(!vis[j]&&dist[v]+adj[v][j]<dist[j])
dist[j]=dist[v]+adj[v][j],pre[j]=v;
}
}
int main()
{
int n,src;
scanf("%d",&n);
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++){
scanf("%d",&adj[i][j]);
if(adj[i][j]==-1) adj[i][j]=inf;
}
scanf("%d",&src);
int tot=-1;
while(~scanf("%d",&x[++tot])){
dijkstra(x[tot],n);
p[tot].id=x[tot],p[tot].lowcost=dist[src];
int tmp=src;
while(pre[tmp]!=-1){
p[tot].path[p[tot].sz++]=tmp;
tmp=pre[tmp];
}
p[tot].path[p[tot].sz]=tmp;
}
sort(p,p+tot);
puts("Org\tDest\tTime\tPath");
for(int i=0;i<tot;i++){
printf("%d\t%d\t%d",p[i].id,src,p[i].lowcost);
for(int j=p[i].sz;j>=0;j--)
printf("\t%d",p[i].path[j]);
puts("");
}
return 0;
}
后来想了想,这题可以反向建图啊,这样的话终点变起点,起点变终点,那么一遍dijkstra即可,而且无需开数组记录了,两全其美啊。

代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#define Maxn 30
using namespace std;

int adj[Maxn][Maxn];
int x[Maxn],dist[Maxn],vis[Maxn],pre[Maxn];
const int inf=0x3f3f3f3f;
void dijkstra(int u,int n){
for(int i=1;i<=n;i++)
dist[i]=adj[u][i],vis[i]=0,pre[i]=u;
vis[u]=1,pre[u]=-1;
for(int i=1;i<n;i++){
int minn=inf,v;
for(int j=1;j<=n;j++)
if(!vis[j]&&dist[j]<minn)
minn=dist[j],v=j;
vis[v]=1;
for(int j=1;j<=n;j++)
if(!vis[j]&&dist[v]+adj[v][j]<dist[j])
dist[j]=dist[v]+adj[v][j],pre[j]=v;
}
}
bool cmp(const int &a,const int &b){
return dist[a]<dist[b];
}
int main()
{
int n,src;
scanf("%d",&n);
for(int j=1;j<=n;j++)
for(int i=1;i<=n;i++){
scanf("%d",&adj[i][j]);
if(adj[i][j]==-1) adj[i][j]=inf;
}
scanf("%d",&src);
dijkstra(src,n);
int tot=-1;
while(~scanf("%d",&x[++tot]));
sort(x,x+tot,cmp);
puts("Org\tDest\tTime\tPath");
for(int i=0;i<tot;i++){
printf("%d\t%d\t%d",x[i],src,dist[x[i]]);
int tmp=x[i];
while(pre[tmp]!=-1) {printf("\t%d",tmp);tmp=pre[tmp];}
printf("\t%d\n",tmp);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: