您的位置:首页 > 其它

[NWPU][2014][TRN][22]RMQ和LCA E - LCA POJ 1470

2014-09-06 21:13 302 查看
E - LCA
Time Limit:2000MS Memory Limit:10000KB 64bit IO Format:%I64d
& %I64u
Submit Status Practice POJ
1470

Description

Write a program that takes as input a rooted tree and a list of pairs of vertices. For each pair (u,v) the program determines the closest common ancestor of u and v in the tree. The closest common ancestor of two nodes u and v is the node w that is an ancestor
of both u and v and has the greatest depth in the tree. A node can be its own ancestor (for example in Figure 1 the ancestors of node 2 are 2 and 5)

Input

The data set, which is read from a the std input, starts with the tree description, in the form:

nr_of_vertices

vertex:(nr_of_successors) successor1 successor2 ... successorn

...

where vertices are represented as integers from 1 to n ( n <= 900 ). The tree description is followed by a list of pairs of vertices, in the form:

nr_of_pairs

(u v) (x y) ...

The input file contents several data sets (at least one).

Note that white-spaces (tabs, spaces and line breaks) can be used freely in the input.

Output

For each common ancestor the program prints the ancestor and the number of pair for which it is an ancestor. The results are printed on the standard output on separate lines, in to the ascending order of the vertices, in the format: ancestor:times

For example, for the following tree:



Sample Input

5
5:(3) 1 4 2
1:(0)
4:(0)
2:(1) 3
3:(0)
6
(1 5) (1 4) (4 2)
(2 3)
(1 3) (4 3)


Sample Output

2:1
5:5


Hint

Huge input, scanf is recommended.

//@auther Yang Zongjun
#include <iostream>
#include <cstdio>
#include <vector>
#include <string.h>
//#include <string>
#include <cstring>

using namespace std;
#define PI acos(-1.0)
#define EPS 1e-8
const int N = 1005;
const int INF = 2100000000;

vector<int> edge
;
int query

,father
,count
,indeg
;
int vis
,n,m;

int findSet(int x){
if(x!=father[x]){
father[x]=findSet(father[x]);
}
return father[x];
}

void Tarjan(int u){
father[u]=u;
for(int i=0;i<edge[u].size();i++){
Tarjan(edge[u][i]);
father[edge[u][i]]=u;
}
vis[u]=1;
for(int i=1;i<=n;i++)
if(vis[i] && query[u][i])
count[findSet(i)]+=query[u][i];
}

int main()
{
//freopen("C:/Users/Admin/Desktop/input.txt", "r", stdin);
//while(cin >> n)
while(scanf("%d", &n) != EOF)
{
//cin >> n;
//while(n--)
//{
for(int i = 1; i <= n; i++)
{
edge[i].clear();
}
memset(query, 0, sizeof(query));
memset(vis, 0, sizeof(vis));
memset(count, 0, sizeof(count));
memset(indeg, 0, sizeof(indeg));
int u, v, num; char c;
int t = n;
while(t--)
//for(int j = 0; j < n; j++)
{
//cin >> u >> c >> c >> num >> c;
scanf("%d:(%d)", &u, &num);
//cout << u << "  " << num << u + num << endl;
while(num--)
{
//cin >> v;//cout << v << endl;
scanf(" %d", &v);
edge[u].push_back(v);
indeg[v]++;
}
}

//}
scanf("%d", &m);
//int u, v; char c;
while(m--)
{
scanf(" (%d %d)", &u, &v);
//cin >> c >> u >> v >> c;
//cout << u << v << endl;
query[u][v]++;
query[v][u]++;
}
for(int i = 1; i <= n; i++)
{
if(indeg[i] == 0)
{
Tarjan(i);break;
}
}
for(int i = 1; i <= n; i++)
{
if(count[i])
{
//cout << i << ":" << count[i] << endl;
printf("%d:%d\n", i, count[i]);
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: