您的位置:首页 > 产品设计 > UI/UE

ZOJ 3659 Conquer a New Region

2014-09-06 21:09 330 查看

Conquer a New Region

Time Limit: 5000ms
Memory Limit: 32768KB
This problem will be judged on ZJU. Original ID: 3659
64-bit integer IO format: %lld Java class name: Main

The wheel of the history rolling forward, our king conquered a new region in a distant continent.

There are N towns (numbered from 1 to N) in this region connected by several roads. It's confirmed that there is exact one route between any two towns. Traffic is important while controlled colonies are far away from the local country. We define the capacity C(i, j) of a road indicating it is allowed to transport at most C(i, j) goods between town i and town j if there is a road between them. And for a route between i and j, we define a value S(i, j) indicating the maximum traffic capacity between i and j which is equal to the minimum capacity of the roads on the route.

Our king wants to select a center town to restore his war-resources in which the total traffic capacities from the center to the other N - 1 towns is maximized. Now, you, the best programmer in the kingdom, should help our king to select this center.

Input

There are multiple test cases.

The first line of each case contains an integer N. (1 ≤ N ≤ 200,000)

The next N - 1 lines each contains three integers a, b, c indicating there is a road between town a and town b whose capacity is c. (1 ≤ a, b ≤ N, 1 ≤ c ≤ 100,000)

Output

For each test case, output an integer indicating the total traffic capacity of the chosen center town.

Sample Input

4
1 2 2
2 4 1
2 3 1
4
1 2 1
2 4 1
2 3 1

Sample Output

4
3


Source

The 2012 ACM-ICPC Asia Changchun Regional Contest

解题:并查集的高级应用。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <climits>
#include <vector>
#include <queue>
#include <cstdlib>
#include <string>
#include <set>
#include <stack>
#define LL long long
#define pii pair<int,int>
#define INF 0x3f3f3f3f
using namespace std;
const int maxn = 200100;
struct arc{
int u,v,w;
arc(int x = 0,int y = 0,int z = 0){
u = x;
v = y;
w = z;
}
};
int uf[maxn],rank_[maxn],tot;
LL d[maxn];
arc e[maxn];
bool cmp(const arc &x,const arc &y){
return x.w > y.w;
}
int Find(int x){
if(x == uf[x]) return uf[x];
return uf[x] = Find(uf[x]);
}
void Union(int x,int y,LL z){
uf[x] = y;
rank_[y] += rank_[x];
d[y] = z;
}
int main() {
int n;
while(~scanf("%d",&n)){
for(int i = 1; i < n; i++)
scanf("%d %d %d",&e[i].u,&e[i].v,&e[i].w);
for(int i = 0; i < maxn; i++){
uf[i] = i;
rank_[i] = 1;
d[i] = 0;
}
sort(e+1,e+n,cmp);
for(int i = 1; i < n; i++){
int x = Find(e[i].u);
int y = Find(e[i].v);
LL sx = d[x] + (LL)e[i].w*rank_[y];
LL sy = d[y] + (LL)e[i].w*rank_[x];
if(sx > sy) Union(y,x,sx);
else Union(x,y,sy);
}
printf("%I64d\n",d[Find(1)]);
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: